aboutsummaryrefslogtreecommitdiff
path: root/print/cloudprint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/cloudprint/Makefile')
-rw-r--r--print/cloudprint/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/print/cloudprint/Makefile b/print/cloudprint/Makefile
index 09100156eaa4..84cdb5ae844a 100644
--- a/print/cloudprint/Makefile
+++ b/print/cloudprint/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cloudprint
PORTVERSION= 0.11.20140215
+PORTREVISION= 1
CATEGORIES= print
MAINTAINER= decke@FreeBSD.org
@@ -10,7 +11,8 @@ COMMENT= Google Cloud Print proxy for local CUPS printers
LICENSE= GPLv3
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/cups.so:${PORTSDIR}/print/py-cups
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/cups.so:${PORTSDIR}/print/py-cups \
+ ${PYTHON_PKGNAMEPREFIX}daemon>0:${PORTSDIR}/devel/py-daemon
USE_GITHUB= yes
GH_ACCOUNT= armooo
@@ -19,5 +21,13 @@ GH_COMMIT= 07e4711
USE_PYTHON= 2
USE_PYDISTUTILS= yes
+USE_RC_SUBR= ${PORTNAME}
+
+USERS= cups
+GROUPS= cups
+
+SUB_LIST+= PYTHON_CMD="${PYTHON_CMD}" \
+ CPUSER="${USERS}" \
+ CPGROUP="${GROUPS}"
.include <bsd.port.mk>