aboutsummaryrefslogtreecommitdiff
path: root/print/cpp2latex
diff options
context:
space:
mode:
Diffstat (limited to 'print/cpp2latex')
-rw-r--r--print/cpp2latex/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/print/cpp2latex/Makefile b/print/cpp2latex/Makefile
index 99ce71f4c256..282d7af5ddaf 100644
--- a/print/cpp2latex/Makefile
+++ b/print/cpp2latex/Makefile
@@ -17,12 +17,18 @@ COMMENT= Convert C++ source to a file you can input in an LaTeX-document
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile on FreeBSD ${OSVERSION}"
+.endif
+
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
-.for file in AUTHORS ChangeLog README TODO
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.for docfile in AUTHORS ChangeLog README TODO
+ ${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>