aboutsummaryrefslogtreecommitdiff
path: root/print/cups/Makefile.common
diff options
context:
space:
mode:
Diffstat (limited to 'print/cups/Makefile.common')
-rw-r--r--print/cups/Makefile.common43
1 files changed, 37 insertions, 6 deletions
diff --git a/print/cups/Makefile.common b/print/cups/Makefile.common
index 681142694359..7bc74296c88e 100644
--- a/print/cups/Makefile.common
+++ b/print/cups/Makefile.common
@@ -1,23 +1,54 @@
# Common file for CUPS ports
# $FreeBSD$
-MASTER_SITES= ftp://ftp.easysw.com/pub/cups/${CUPS_VERSION}/ \
- ftp://ftp2.easysw.com/pub/cups/${CUPS_VERSION}/ \
+MASTER_SITES= \
ftp://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/cups/${CUPS_VERSION}/ \
+ ftp://ftp.ntua.gr/pub/gnu/cups/${CUPS_VERSION}/ \
+ ftp://ftp.easysw.com/pub/cups/${CUPS_VERSION}/ \
+ ftp://ftp.fisek.com.tr/pub/cups/${CUPS_VERSION}/ \
ftp://ftp.mpg.goe.ni.schule.de/pub/internet/printing/cups/${CUPS_VERSION}/
-CUPS_VERSION= 1.1.14
+CUPS_VERSION= 1.1.15
+CUPS_REVISION= 1
+CUPS_PORTVER= ${CUPS_VERSION}.${CUPS_REVISION}
+
+.ifdef CUPS_FR
+MANLANG= "" fr
+.else
+EXTRA_PATCHES=${.CURDIR}/../../print/cups/files/fr-patch-man-Makefile
+.endif
+
+EXTRA_PATCHES+=${.CURDIR}/../../print/cups/files/patch-man-Makefile
+EXTRA_PATCHES+=${.CURDIR}/../../print/cups/files/patch-man-fr-Makefile
+EXTRA_PATCHES+=${.CURDIR}/../../print/cups/files/patch-config-scripts-cups-common.m4
+EXTRA_PATCHES+=${.CURDIR}/../../print/cups/files/patch-Makedefs.in
#protect the base port
-.if( $(PORTNAME) != "cups")
-DISTNAME= cups-${CUPS_VERSION}-source
+.if ${PORTNAME} != "cups"
+DISTNAME= cups-${CUPS_VERSION}-${CUPS_REVISION}-source
+#DISTNAME= cups-${CUPS_VERSION}-source
DISTFILES= ${DISTNAME}.tar.bz2
WRKSRC= ${WRKDIR}/cups-${CUPS_VERSION}
USE_BZIP2= yes
-USE_GMAKE= yes
+#Breaks build.. USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
+CONFIGURE_ENV+= CPPFLAGS="-I${PREFIX}/include"
+CONFIGURE_ENV+= DSOFLAGS="-L${PREFIX}/lib"
+CONFIGURE_ENV+= LDFLAGS="-L${PREFIX}/lib"
+
CONFIGURE_ARGS+= --localstatedir=/var
+
+AUTOCONF= autoconf
+BUILD_DEPENDS+= autoconf:${PORTSDIR}/devel/autoconf
+
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
+post-patch::
+ cd ${WRKSRC}; ${AUTOCONF} --force
.endif