aboutsummaryrefslogtreecommitdiff
path: root/print/cups/Makefile.common
diff options
context:
space:
mode:
Diffstat (limited to 'print/cups/Makefile.common')
-rw-r--r--print/cups/Makefile.common23
1 files changed, 23 insertions, 0 deletions
diff --git a/print/cups/Makefile.common b/print/cups/Makefile.common
new file mode 100644
index 000000000000..2054c4f1cb69
--- /dev/null
+++ b/print/cups/Makefile.common
@@ -0,0 +1,23 @@
+# Common file for CUPS ports
+# $FreeBSD$
+
+MASTER_SITES= ftp://ftp.easysw.com/pub/cups/${VERSION}/ \
+ ftp://ftp2.easysw.com/pub/cups/${VERSION}/ \
+ ftp://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/cups/${VERSION}/ \
+ ftp://ftp.mpg.goe.ni.schule.de/pub/internet/printing/cups/${VERSION}/
+
+CUPS_VERSION= 1.1.14
+
+#protect the base port
+.if( $(PORTNAME) != "cups")
+DISTNAME= cups-${CUPS_VERSION}-source
+DISTFILES= ${DISTNAME}.tar.bz2
+WRKSRC= ${WRKDIR}/cups-${CUPS_VERSION}
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS+= --localstatedir=/var
+.endif
+