aboutsummaryrefslogtreecommitdiff
path: root/print/cups
diff options
context:
space:
mode:
Diffstat (limited to 'print/cups')
-rw-r--r--print/cups/Makefile11
-rw-r--r--print/cups/Makefile.common43
-rw-r--r--print/cups/Makefile.inc43
-rw-r--r--print/cups/distinfo1
-rw-r--r--print/cups/files/fr-patch-man-Makefile11
-rw-r--r--print/cups/files/patch-Makedefs.in13
-rw-r--r--print/cups/files/patch-config-scripts-cups-common.m411
7 files changed, 115 insertions, 18 deletions
diff --git a/print/cups/Makefile b/print/cups/Makefile
index b3ecfed52664..39cfddeb740a 100644
--- a/print/cups/Makefile
+++ b/print/cups/Makefile
@@ -6,19 +6,20 @@
#
PORTNAME= cups
-PORTVERSION= ${CUPS_VERSION}
-CATEGORIES= print
+PORTVERSION= ${CUPS_PORTVER}
+CATEGORIES?= print
MASTER_SITES= # empty
DISTFILES= # none
EXTRACT_ONLY= # empty
MAINTAINER= jah4007@cs.rit.edu
-LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-base
-RUN_DEPENDS= ${LOCALBASE}/sbin/cupsaddsmb:${PORTSDIR}/print/cups-lpr
+LIB_DEPENDS?= cups.2:${.CURDIR}/../../print/cups-base
+RUN_DEPENDS?= ${LOCALBASE}/sbin/cupsaddsmb:${.CURDIR}/../../print/cups-lpr
NO_BUILD= true
do-install: # empty
+do-patch: # empty
-.include "${.CURDIR}/Makefile.inc"
+.include "${.CURDIR}/../../print/cups/Makefile.inc"
.include <bsd.port.mk>
diff --git a/print/cups/Makefile.common b/print/cups/Makefile.common
index 681142694359..7bc74296c88e 100644
--- a/print/cups/Makefile.common
+++ b/print/cups/Makefile.common
@@ -1,23 +1,54 @@
# Common file for CUPS ports
# $FreeBSD$
-MASTER_SITES= ftp://ftp.easysw.com/pub/cups/${CUPS_VERSION}/ \
- ftp://ftp2.easysw.com/pub/cups/${CUPS_VERSION}/ \
+MASTER_SITES= \
ftp://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/cups/${CUPS_VERSION}/ \
+ ftp://ftp.ntua.gr/pub/gnu/cups/${CUPS_VERSION}/ \
+ ftp://ftp.easysw.com/pub/cups/${CUPS_VERSION}/ \
+ ftp://ftp.fisek.com.tr/pub/cups/${CUPS_VERSION}/ \
ftp://ftp.mpg.goe.ni.schule.de/pub/internet/printing/cups/${CUPS_VERSION}/
-CUPS_VERSION= 1.1.14
+CUPS_VERSION= 1.1.15
+CUPS_REVISION= 1
+CUPS_PORTVER= ${CUPS_VERSION}.${CUPS_REVISION}
+
+.ifdef CUPS_FR
+MANLANG= "" fr
+.else
+EXTRA_PATCHES=${.CURDIR}/../../print/cups/files/fr-patch-man-Makefile
+.endif
+
+EXTRA_PATCHES+=${.CURDIR}/../../print/cups/files/patch-man-Makefile
+EXTRA_PATCHES+=${.CURDIR}/../../print/cups/files/patch-man-fr-Makefile
+EXTRA_PATCHES+=${.CURDIR}/../../print/cups/files/patch-config-scripts-cups-common.m4
+EXTRA_PATCHES+=${.CURDIR}/../../print/cups/files/patch-Makedefs.in
#protect the base port
-.if( $(PORTNAME) != "cups")
-DISTNAME= cups-${CUPS_VERSION}-source
+.if ${PORTNAME} != "cups"
+DISTNAME= cups-${CUPS_VERSION}-${CUPS_REVISION}-source
+#DISTNAME= cups-${CUPS_VERSION}-source
DISTFILES= ${DISTNAME}.tar.bz2
WRKSRC= ${WRKDIR}/cups-${CUPS_VERSION}
USE_BZIP2= yes
-USE_GMAKE= yes
+#Breaks build.. USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
+CONFIGURE_ENV+= CPPFLAGS="-I${PREFIX}/include"
+CONFIGURE_ENV+= DSOFLAGS="-L${PREFIX}/lib"
+CONFIGURE_ENV+= LDFLAGS="-L${PREFIX}/lib"
+
CONFIGURE_ARGS+= --localstatedir=/var
+
+AUTOCONF= autoconf
+BUILD_DEPENDS+= autoconf:${PORTSDIR}/devel/autoconf
+
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
+post-patch::
+ cd ${WRKSRC}; ${AUTOCONF} --force
.endif
diff --git a/print/cups/Makefile.inc b/print/cups/Makefile.inc
index 681142694359..7bc74296c88e 100644
--- a/print/cups/Makefile.inc
+++ b/print/cups/Makefile.inc
@@ -1,23 +1,54 @@
# Common file for CUPS ports
# $FreeBSD$
-MASTER_SITES= ftp://ftp.easysw.com/pub/cups/${CUPS_VERSION}/ \
- ftp://ftp2.easysw.com/pub/cups/${CUPS_VERSION}/ \
+MASTER_SITES= \
ftp://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/cups/${CUPS_VERSION}/ \
+ ftp://ftp.ntua.gr/pub/gnu/cups/${CUPS_VERSION}/ \
+ ftp://ftp.easysw.com/pub/cups/${CUPS_VERSION}/ \
+ ftp://ftp.fisek.com.tr/pub/cups/${CUPS_VERSION}/ \
ftp://ftp.mpg.goe.ni.schule.de/pub/internet/printing/cups/${CUPS_VERSION}/
-CUPS_VERSION= 1.1.14
+CUPS_VERSION= 1.1.15
+CUPS_REVISION= 1
+CUPS_PORTVER= ${CUPS_VERSION}.${CUPS_REVISION}
+
+.ifdef CUPS_FR
+MANLANG= "" fr
+.else
+EXTRA_PATCHES=${.CURDIR}/../../print/cups/files/fr-patch-man-Makefile
+.endif
+
+EXTRA_PATCHES+=${.CURDIR}/../../print/cups/files/patch-man-Makefile
+EXTRA_PATCHES+=${.CURDIR}/../../print/cups/files/patch-man-fr-Makefile
+EXTRA_PATCHES+=${.CURDIR}/../../print/cups/files/patch-config-scripts-cups-common.m4
+EXTRA_PATCHES+=${.CURDIR}/../../print/cups/files/patch-Makedefs.in
#protect the base port
-.if( $(PORTNAME) != "cups")
-DISTNAME= cups-${CUPS_VERSION}-source
+.if ${PORTNAME} != "cups"
+DISTNAME= cups-${CUPS_VERSION}-${CUPS_REVISION}-source
+#DISTNAME= cups-${CUPS_VERSION}-source
DISTFILES= ${DISTNAME}.tar.bz2
WRKSRC= ${WRKDIR}/cups-${CUPS_VERSION}
USE_BZIP2= yes
-USE_GMAKE= yes
+#Breaks build.. USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
+CONFIGURE_ENV+= CPPFLAGS="-I${PREFIX}/include"
+CONFIGURE_ENV+= DSOFLAGS="-L${PREFIX}/lib"
+CONFIGURE_ENV+= LDFLAGS="-L${PREFIX}/lib"
+
CONFIGURE_ARGS+= --localstatedir=/var
+
+AUTOCONF= autoconf
+BUILD_DEPENDS+= autoconf:${PORTSDIR}/devel/autoconf
+
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
+post-patch::
+ cd ${WRKSRC}; ${AUTOCONF} --force
.endif
diff --git a/print/cups/distinfo b/print/cups/distinfo
deleted file mode 100644
index f871858bea1c..000000000000
--- a/print/cups/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (cups-1.1.14-source.tar.bz2) = 7cc9725d94568b24f5ade78fb7e26480
diff --git a/print/cups/files/fr-patch-man-Makefile b/print/cups/files/fr-patch-man-Makefile
new file mode 100644
index 000000000000..8984c09cc949
--- /dev/null
+++ b/print/cups/files/fr-patch-man-Makefile
@@ -0,0 +1,11 @@
+--- man/Makefile.fr Fri Jun 7 21:02:51 2002
++++ man/Makefile Fri Jun 7 21:03:00 2002
+@@ -30,7 +30,7 @@
+ # Other languages...
+ #
+
+-LANGDIRS = fr
++LANGDIRS =
+
+
+ #
diff --git a/print/cups/files/patch-Makedefs.in b/print/cups/files/patch-Makedefs.in
new file mode 100644
index 000000000000..d62032fdda40
--- /dev/null
+++ b/print/cups/files/patch-Makedefs.in
@@ -0,0 +1,13 @@
+--- Makedefs.in.orig Tue Jun 4 16:32:02 2002
++++ Makedefs.in Tue Jul 2 03:13:20 2002
+@@ -83,8 +83,8 @@
+ #
+
+ ARFLAGS = @ARFLAGS@
+-CFLAGS = $(RC_CFLAGS) @CFLAGS@ -I.. $(OPTIONS)
+-CXXFLAGS = $(RC_CFLAGS) @CXXFLAGS@ -I.. $(OPTIONS)
++CFLAGS = $(RC_CFLAGS) @CFLAGS@ -I.. @CPPFLAGS@ $(OPTIONS)
++CXXFLAGS = $(RC_CFLAGS) @CXXFLAGS@ -I.. @CPPFLAGS@ $(OPTIONS)
+ CXXLIBS = @CXXLIBS@
+ DSOFLAGS = @DSOFLAGS@
+ DSOLIBS = @DSOLIBS@
diff --git a/print/cups/files/patch-config-scripts-cups-common.m4 b/print/cups/files/patch-config-scripts-cups-common.m4
new file mode 100644
index 000000000000..eca3c6914b31
--- /dev/null
+++ b/print/cups/files/patch-config-scripts-cups-common.m4
@@ -0,0 +1,11 @@
+--- config-scripts/cups-common.m4.orig Tue Jun 4 16:58:55 2002
++++ config-scripts/cups-common.m4 Tue Jul 2 02:18:13 2002
+@@ -88,7 +88,7 @@
+ AC_HEADER_STDC
+ AC_HEADER_DIRENT
+ AC_CHECK_HEADER(crypt.h,AC_DEFINE(HAVE_CRYPT_H))
+-AC_CHECK_HEADER(malloc.h,AC_DEFINE(HAVE_MALLOC_H))
++dnl AC_CHECK_HEADER(malloc.h,AC_DEFINE(HAVE_MALLOC_H))
+ AC_CHECK_HEADER(shadow.h,AC_DEFINE(HAVE_SHADOW_H))
+ AC_CHECK_HEADER(string.h,AC_DEFINE(HAVE_STRING_H))
+ AC_CHECK_HEADER(strings.h,AC_DEFINE(HAVE_STRINGS_H))