aboutsummaryrefslogtreecommitdiff
path: root/print/ggv2/files
diff options
context:
space:
mode:
Diffstat (limited to 'print/ggv2/files')
-rw-r--r--print/ggv2/files/patch-aa25
-rw-r--r--print/ggv2/files/patch-ad6
-rw-r--r--print/ggv2/files/patch-ae11
-rw-r--r--print/ggv2/files/patch-af6
-rw-r--r--print/ggv2/files/patch-configure17
-rw-r--r--print/ggv2/files/patch-ltmain.sh28
-rw-r--r--print/ggv2/files/patch-src::Makefile.in14
-rw-r--r--print/ggv2/files/patch-src::gtkgs.c11
8 files changed, 17 insertions, 101 deletions
diff --git a/print/ggv2/files/patch-aa b/print/ggv2/files/patch-aa
deleted file mode 100644
index 984e279f6233..000000000000
--- a/print/ggv2/files/patch-aa
+++ /dev/null
@@ -1,25 +0,0 @@
-
-$FreeBSD$
-
---- configure 2001/11/12 12:25:30 1.1
-+++ configure 2001/11/12 12:25:34
-@@ -10454,15 +10454,15 @@
- echo "${ECHO_T}no" >&6
- fi
-
-- USE_INCLUDED_LIBINTL=yes
-+# USE_INCLUDED_LIBINTL=yes
- CATOBJEXT=.gmo
- INSTOBJEXT=.mo
- DATADIRNAME=share
-- INTLDEPS='$(top_builddir)/intl/libintl.a'
-+ INTLDEPS='-lintl'
- INTLLIBS=$INTLDEPS
- LIBS=`echo $LIBS | sed -e 's/-lintl//'`
-- nls_cv_header_intl=intl/libintl.h
-- nls_cv_header_libgt=intl/libgettext.h
-+# nls_cv_header_intl=intl/libintl.h
-+# nls_cv_header_libgt=intl/libgettext.h
- fi
-
- if test "$XGETTEXT" != ":"; then
diff --git a/print/ggv2/files/patch-ad b/print/ggv2/files/patch-ad
deleted file mode 100644
index d346879b7abe..000000000000
--- a/print/ggv2/files/patch-ad
+++ /dev/null
@@ -1,6 +0,0 @@
---- src/ps.h.orig Tue Feb 13 12:21:25 2001
-+++ src/ps.h Tue Feb 27 18:50:19 2001
-@@ -45,2 +45,3 @@
-
-+#undef NONE
- enum { ATEND = -1, NONE = 0, PORTRAIT, LANDSCAPE, ASCEND, DESCEND, SPECIAL };
diff --git a/print/ggv2/files/patch-ae b/print/ggv2/files/patch-ae
deleted file mode 100644
index 6a062e098c79..000000000000
--- a/print/ggv2/files/patch-ae
+++ /dev/null
@@ -1,11 +0,0 @@
---- po/Makefile.in.in.orig Tue Feb 17 00:59:01 1998
-+++ po/Makefile.in.in Tue May 16 12:57:23 2000
-@@ -19,7 +19,7 @@
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- datadir = $(prefix)/@DATADIRNAME@
--localedir = $(datadir)/locale
-+localedir = $(prefix)/share/locale
- gnulocaledir = $(prefix)/share/locale
- gettextsrcdir = $(prefix)/share/gettext/po
- subdir = po
diff --git a/print/ggv2/files/patch-af b/print/ggv2/files/patch-af
deleted file mode 100644
index 6f2b5511f022..000000000000
--- a/print/ggv2/files/patch-af
+++ /dev/null
@@ -1,6 +0,0 @@
---- app-docs.make.orig Tue Mar 27 14:36:27 2001
-+++ app-docs.make Tue Apr 17 19:42:48 2001
-@@ -1,2 +1,2 @@
--helpdir = $(datadir)/gnome/help/$(app)/$(lang)
-+helpdir = $(datadir)/help/$(app)/$(lang)
- help_DATA = \
diff --git a/print/ggv2/files/patch-configure b/print/ggv2/files/patch-configure
new file mode 100644
index 000000000000..113117d728ef
--- /dev/null
+++ b/print/ggv2/files/patch-configure
@@ -0,0 +1,17 @@
+--- configure.orig Sun Jul 7 18:20:21 2002
++++ configure Sun Jul 7 18:20:31 2002
+@@ -12015,12 +12015,12 @@
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; }; then
+ CATOBJEXT=.gmo
+- DATADIRNAME=share
++ DATADIRNAME=share/gnome
+ else
+ echo "$as_me: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+ CATOBJEXT=.mo
+- DATADIRNAME=share
++ DATADIRNAME=share/gnome
+ fi
+ rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
+ INSTOBJEXT=.mo
diff --git a/print/ggv2/files/patch-ltmain.sh b/print/ggv2/files/patch-ltmain.sh
deleted file mode 100644
index 98cb05e4ddb3..000000000000
--- a/print/ggv2/files/patch-ltmain.sh
+++ /dev/null
@@ -1,28 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh 2001/08/27 09:51:26 1.1
-+++ ltmain.sh 2001/08/27 09:51:42
-@@ -2408,6 +2408,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4175,10 +4178,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/print/ggv2/files/patch-src::Makefile.in b/print/ggv2/files/patch-src::Makefile.in
deleted file mode 100644
index 5789553a8881..000000000000
--- a/print/ggv2/files/patch-src::Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/Makefile.in 2001/11/12 12:29:36 1.1
-+++ src/Makefile.in 2001/11/12 12:31:39
-@@ -139,7 +139,7 @@
-
- SUBDIRS = stock
-
--INCLUDES = -I$(includedir) $(GNOME_INCLUDEDIR) -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\"
-+INCLUDES = -I$(includedir) $(GNOME_INCLUDEDIR) -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" $(EXTRA_GNOME_CFLAGS)
-
-
- @BONOBO_TRUE@bonobo_components = bonobo-application-ps
diff --git a/print/ggv2/files/patch-src::gtkgs.c b/print/ggv2/files/patch-src::gtkgs.c
deleted file mode 100644
index 85407be0e274..000000000000
--- a/print/ggv2/files/patch-src::gtkgs.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gtkgs.c.orig Tue Oct 23 23:37:33 2001
-+++ src/gtkgs.c Sat Feb 2 19:14:29 2002
-@@ -1273,7 +1273,7 @@
- fname = ggv_quote_filename (filename);
- filename_dsc = tempnam (g_get_tmp_dir(), "dsc");
- filename_err = tempnam (g_get_tmp_dir(), "err");
-- cmd = g_strdup_printf (gs_scan_pdf_cmd, "\"", fname ,"\"", "\", filename_dsc");
-+ cmd = g_strdup_printf (gs_scan_pdf_cmd, fname, filename_dsc);
- g_free (fname);
- /* this command (sometimes?) prints error messages to stdout! */
- cmdline = g_strdup_printf ("%s >%s 2>&1", cmd, filename_err);