aboutsummaryrefslogtreecommitdiff
path: root/print/ghostscript6/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/ghostscript6/Makefile')
-rw-r--r--print/ghostscript6/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/print/ghostscript6/Makefile b/print/ghostscript6/Makefile
index c0c5b7e65834..1548a0e269a3 100644
--- a/print/ghostscript6/Makefile
+++ b/print/ghostscript6/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ghostscript
PORTVERSION= 6.50
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= print
MASTER_SITES= ftp://ftp.fh-koblenz.de/pub/Ghostscript/aladdin/gs650/ \
ftp://ftp.fh-koblenz.de/pub/Ghostscript/aladdin/fonts/ \
@@ -39,7 +39,16 @@ LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png
WRKSRC= ${WRKDIR}/gs${PORTVERSION}
ALL_TARGET= all pcl3opts escputil
+
+.if !defined(NO_X)
USE_XLIB= yes
+.else
+# XXX Hack. If you've done something like "-DNO_X" on the command line
+# (instead of NO_X=true, or similar) gmake won't pick it up. So make sure
+# that NO_X is defined *and* has a value.
+MAKE_ENV+= NO_X=true
+.endif
+
USE_GMAKE= yes
MAKEFILE= src/unix-gcc.mak
PLIST_SUB= GS_VERSION=${PORTVERSION}