aboutsummaryrefslogtreecommitdiff
path: root/print/ghostscript7/files/Makefile.alps
diff options
context:
space:
mode:
Diffstat (limited to 'print/ghostscript7/files/Makefile.alps')
-rw-r--r--print/ghostscript7/files/Makefile.alps22
1 files changed, 22 insertions, 0 deletions
diff --git a/print/ghostscript7/files/Makefile.alps b/print/ghostscript7/files/Makefile.alps
new file mode 100644
index 000000000000..e30c5e793912
--- /dev/null
+++ b/print/ghostscript7/files/Makefile.alps
@@ -0,0 +1,22 @@
+# $FreeBSD$
+# ALPS - additional driver for Alps MD-5000
+
+DISTFILES+= gdevalps-0.21.tar.gz:ports_jp_gs
+EXTRADEVMKFILE+= ${WRKSRC}/alps/gdevalps.mak-5.50
+PORTDOCS+= alps
+
+post-extract-alps:
+ ${TAR} -C ${WRKSRC} -xzf ${DISTDIR}/${DIST_SUBDIR}/gdevalps-0.21.tar.gz
+ ${LN} -s -f gdevalps-0.2 ${WRKSRC}/alps
+
+pre-build-alps:
+ ${LN} -s -f ${WRKSRC}/alps/gdevalps.c ${WRKSRC}/src
+
+post-install-docs-alps:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/alps
+ ${INSTALL_DATA} ${WRKSRC}/alps/README.gdevalps \
+ ${STAGEDIR}${DOCSDIR}/alps
+
+post-extract: post-extract-alps
+pre-build: pre-build-alps
+post-install-docs: post-install-docs-alps