aboutsummaryrefslogtreecommitdiff
path: root/print/ghostscript8/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/ghostscript8/Makefile')
-rw-r--r--print/ghostscript8/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/print/ghostscript8/Makefile b/print/ghostscript8/Makefile
index ead4761f1346..6e4971d8732e 100644
--- a/print/ghostscript8/Makefile
+++ b/print/ghostscript8/Makefile
@@ -170,8 +170,9 @@ post-patch:
${PERL} -pi -e 's|\. de|\.|g' \
${WRKSRC}/src/unixinst.mak
# for HPinkjet driver
- ${PERL} -pi -e 's|CFLAGS="-O2 -Wall"||g ; \
- s|CXXFLAGS="-O2 -Wall"||g' ${WRKSRC}/${HPIJS_NAME}/configure
+ ${PERL} -pi -e 's|CFLAGS="-O2 -Wall"|CFLAGS="\$$CFLAGS -O0"|g ; \
+ s|CXXFLAGS="-O2 -Wall"|CXXFLAGS="\$$CXXFLAGS -O0"|g' \
+ ${WRKSRC}/${HPIJS_NAME}/configure
find ${WRKSRC}/${HPIJS_NAME} -name '*.h' | xargs ${PERL} -pi -e \
's|#include <malloc.h>||g'