aboutsummaryrefslogtreecommitdiff
path: root/print/gnome-print/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/gnome-print/Makefile')
-rw-r--r--print/gnome-print/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/print/gnome-print/Makefile b/print/gnome-print/Makefile
index 463d35f314ea..ea3eae7f3a1f 100644
--- a/print/gnome-print/Makefile
+++ b/print/gnome-print/Makefile
@@ -26,10 +26,16 @@ USE_PERL5= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
- --datadir=${PREFIX}/share/gnome \
- --with-gnome=${PREFIX}
+ --datadir=${PREFIX}/share/gnome
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>