aboutsummaryrefslogtreecommitdiff
path: root/print/gsfonts/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/gsfonts/Makefile')
-rw-r--r--print/gsfonts/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/print/gsfonts/Makefile b/print/gsfonts/Makefile
index 44bbac906858..00afc408954d 100644
--- a/print/gsfonts/Makefile
+++ b/print/gsfonts/Makefile
@@ -15,8 +15,14 @@ DISTFILES= ${GS_FONTS_STD} ${GS_FONTS_OTHER}
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/bin/type1inst:${PORTSDIR}/x11-fonts/p5-type1inst \
- ${X11BASE}/bin/mkfontdir:${PORTSDIR}/x11/XFree86
+BUILD_DEPENDS= ${LOCALBASE}/bin/type1inst:${PORTSDIR}/x11-fonts/p5-type1inst
+
+.include <bsd.port.pre.mk>
+.if ${XFREE86_VERSION} == 4
+BUILD_DEPENDS+= ${X11BASE}/bin/mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
+.else
+BUILD_DEPENDS+= ${X11BASE}/bin/mkfontdir:${PORTSDIR}/x11/XFree86
+.endif
NO_BUILD= yes
@@ -30,4 +36,4 @@ do-install:
${TAR} -xzf ${DISTDIR}/${GS_FONTS_STD} -C ${GSDIR}/fonts
(cd ${GSDIR}/fonts; ${LOCALBASE}/bin/type1inst -nogs -nolog -q)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>