aboutsummaryrefslogtreecommitdiff
path: root/print/gutenprint-base/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/gutenprint-base/Makefile')
-rw-r--r--print/gutenprint-base/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/print/gutenprint-base/Makefile b/print/gutenprint-base/Makefile
index 7d99358befda..cf2a71171553 100644
--- a/print/gutenprint-base/Makefile
+++ b/print/gutenprint-base/Makefile
@@ -7,10 +7,10 @@
#
PORTNAME?= gutenprint
-PORTVERSION= 5.1.7
-PORTREVISION?= 2
+PORTVERSION= 5.2.4
+PORTREVISION?= 0
CATEGORIES= print
-MASTER_SITES= SF/gimp-print/gutenprint-5.1/${PORTVERSION}
+MASTER_SITES= SF/gimp-print/gutenprint-5.2/${PORTVERSION}
PKGNAMESUFFIX?= -base
MAINTAINER= ahze@FreeBSD.org
@@ -60,8 +60,7 @@ RUN_DEPENDS+= espgs:${PORTSDIR}/print/cups-pstoraster
CONFIGURE_ARGS+= --with-cups=${PREFIX} \
--enable-cups-ppds \
--enable-cups-level3-ppds
-MAN8+= cups-calibrate.8 cups-genppd.8 cups-genppdconfig.8 \
- cups-genppdupdate.8
+MAN8+= cups-calibrate.8 cups-genppd.8 cups-genppdupdate.8
BUILD_WRKSRC= ${WRKSRC}/src/cups
INSTALL_WRKSRC= ${WRKSRC}/src/cups
.else
@@ -109,6 +108,11 @@ post-patch:
@${REINPLACE_CMD} -e 's|= $$(pkglibdir)|= ${PREFIX}/libexec/cups|' \
${WRKSRC}/src/cups/Makefile.in
+pre-build:
+.if defined(GUT_SLAVE) && (${GUT_SLAVE}=="foomatic" || ${GUT_SLAVE}=="cups")
+ @(cd ${WRKSRC}/src/xml && ${MAKE})
+.endif
+
post-install:
.if ${SLAVE_PORT}=="yes"
@(cd ${WRKSRC}/man && ${GMAKE} ${INSTALL_TARGET})