aboutsummaryrefslogtreecommitdiff
path: root/print/gutenprint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/gutenprint/Makefile')
-rw-r--r--print/gutenprint/Makefile49
1 files changed, 44 insertions, 5 deletions
diff --git a/print/gutenprint/Makefile b/print/gutenprint/Makefile
index b17f432f99e2..f5dcc09cdc88 100644
--- a/print/gutenprint/Makefile
+++ b/print/gutenprint/Makefile
@@ -5,23 +5,62 @@
# $FreeBSD$
PORTNAME= gimp-print
-PORTVERSION= 4.2.0
+PORTVERSION= 4.2.1
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= dgilbert@velocet.ca
-RUN_DEPENDS= gimp:${PORTSDIR}/graphics/gimp1
-LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-base
+LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-cups --with-ghost
USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-gimp=no
INSTALLS_SHLIB= yes
MAN1= escputil.1 gimpprint-config.1
MAN3= gimpprint.3
MAN8= cups-calibrate.8
+.if defined(WITHOUT_CUPS)
+PLIST_SUB+= CUPS="@comment "
+.else
+LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-base
+CONFIGURE_ARGS+= --with-cups=${PREFIX}
+PLIST_SUB+= CUPS=""
+.endif
+
+.if defined(WITHOUT_IJS)
+PLIST_SUB+= IJS="@comment "
+.else
+LIB_DEPENDS= ijs.1:${PORTSDIR}/print/libijs
+CONFIGURE_ARGS+= --with-ijs=yes
+PLIST_SUB+= IJS=""
+.endif
+
+.if defined(NOPORTDOCS)
+CONFIGURE_ARGS+= --with-user-guide=no
+.endif
+
+pre-everything::
+ @${ECHO_MSG}
+ @${ECHO_MSG} "You may use the following build options:"
+ @${ECHO_MSG}
+ @${ECHO_MSG} "WITHOUT_CUPS=yes build without CUPS driver"
+ @${ECHO_MSG} "WITHOUT_IJS=yes build without IJS-based Ghostscript driver"
+ @${ECHO_MSG}
+
+post-extract:
+ @${RM} -f ${WRKSRC}/doc/gimpprint.info*
+
+post-patch:
+ @${PERL} -pi -e 's|makeinfo$$|"makeinfo --no-split"|g ; \
+ s|\$$\{CFLAGS:=\} -O|\$$\{CFLAGS\}|g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
+ 's|\$$\(PACKAGE\)/doc|doc/\$$\(PACKAGE\)|g ; \
+ s|\$$\(RM\) -r|\$$\(RM\) -f -r|g'
+
.include <bsd.port.mk>