aboutsummaryrefslogtreecommitdiff
path: root/print/hpijs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/hpijs/Makefile')
-rw-r--r--print/hpijs/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/print/hpijs/Makefile b/print/hpijs/Makefile
index e30f6763aa6f..a306c372d168 100644
--- a/print/hpijs/Makefile
+++ b/print/hpijs/Makefile
@@ -57,12 +57,13 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hpijs ${PREFIX}/bin
.else
INSTALL_TARGET= install-exec install-foomatic
-.if !defined(WITHOUT_CUPS)
-INSTALL_TARGET+= install-cups
-.endif
.endif
post-install:
+.if !defined(WITHOUT_CUPS)
+ @${LN} -s ${PREFIX}/bin/foomatic-rip ${LOCALBASE}/libexec/cups/filter/foomatic-rip
+ @${LN} -s ${PREFIX}/share/ppd ${LOCALBASE}/share/cups/model/foomatic-ppds
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/gs_hpijs.png ${DOCSDIR}