aboutsummaryrefslogtreecommitdiff
path: root/print/kpdftool/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/kpdftool/Makefile')
-rw-r--r--print/kpdftool/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/print/kpdftool/Makefile b/print/kpdftool/Makefile
index 73bdc16556dd..3a1b1b3b786b 100644
--- a/print/kpdftool/Makefile
+++ b/print/kpdftool/Makefile
@@ -5,8 +5,7 @@
#
PORTNAME= kpdftool
-PORTVERSION= 0.22
-PORTREVISION= 5
+PORTVERSION= 0.23.1
CATEGORIES= print kde
MASTER_SITES= http://www.kde-apps.org/CONTENT/content-files/
DISTFILES= 33194-${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
@@ -14,23 +13,23 @@ DISTFILES= 33194-${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Tool to ease your PDF related work
-BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
-USE_GMAKE= yes
USE_ZIP= yes
-USE_QT_VER= 3
-CONFIGURE_ENV= QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
-MAKE_ARGS+= QTDIR=${QT_PREFIX}
+USE_QT_VER= 4
+QT_COMPONENTS= qt3support moc_build porting_build qmake_build uic3_build
+USE_GHOSTSCRIPT_RUN= yes
MAKE_JOBS_SAFE= yes
+DESKTOP_ENTRIES= "KPDFTool" "${COMMENT}" "kpdftool" \
+ "kpdftool" "" false
+
do-configure:
- cd ${WRKSRC}; \
- ${LOCALBASE}/bin/qmake -spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ ${PORTNAME}.pro;
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-
-PLIST_FILES= bin/kpdftool
+ cd ${WRKSRC}/icons && ${COPYTREE_SHARE} hicolor ${PREFIX}/share/icons/
.include <bsd.port.mk>