aboutsummaryrefslogtreecommitdiff
path: root/print/kpdftool/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/kpdftool/Makefile')
-rw-r--r--print/kpdftool/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/print/kpdftool/Makefile b/print/kpdftool/Makefile
index 80ff746ea242..e0b71a63450d 100644
--- a/print/kpdftool/Makefile
+++ b/print/kpdftool/Makefile
@@ -16,17 +16,13 @@ RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
USE_ZIP= yes
USE_QT4= qt3support moc_build porting_build qmake_build uic3_build
USE_GHOSTSCRIPT_RUN= yes
+USES= qmake
DESKTOP_ENTRIES= "KPDFTool" "${COMMENT}" "kpdftool" \
- "kpdftool" "Qt;Utility;" false
-
-NO_STAGE= yes
-do-configure:
- cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS}
+ "kpdftool" "Qt;Utility;" true
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- cd ${WRKSRC}/icons && ${COPYTREE_SHARE} hicolor ${PREFIX}/share/icons/
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ cd ${WRKSRC}/icons && ${COPYTREE_SHARE} hicolor ${STAGEDIR}${PREFIX}/share/icons/
.include <bsd.port.mk>