aboutsummaryrefslogtreecommitdiff
path: root/print/lilypond-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/lilypond-devel/Makefile')
-rw-r--r--print/lilypond-devel/Makefile38
1 files changed, 20 insertions, 18 deletions
diff --git a/print/lilypond-devel/Makefile b/print/lilypond-devel/Makefile
index ea4f52948e13..364fe74d0d0d 100644
--- a/print/lilypond-devel/Makefile
+++ b/print/lilypond-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= lilypond
-PORTVERSION= 2.17.97
+PORTVERSION= 2.19.0
CATEGORIES= print audio
MASTER_SITES= http://download.linuxaudio.org/lilypond/sources/v${PORTVERSION:R}/
PKGNAMESUFFIX= -devel
@@ -15,38 +15,39 @@ LICENSE= GPLv3
BUILD_DEPENDS= pdftexi2dvi:${PORTSDIR}/print/texinfo \
t1ascii:${PORTSDIR}/print/t1utils \
bash:${PORTSDIR}/shells/bash \
- fontforge:${PORTSDIR}/print/fontforge \
+ convert:${PORTSDIR}/graphics/ImageMagick \
dblatex:${PORTSDIR}/textproc/dblatex \
+ fontforge:${PORTSDIR}/print/fontforge \
+ help2man:${PORTSDIR}/misc/help2man \
pngtopnm:${PORTSDIR}/graphics/netpbm \
rsync:${PORTSDIR}/net/rsync \
+ zip:${PORTSDIR}/archivers/zip \
${LOCALBASE}/share/ghostscript/fonts/c059033l.pfb:${PORTSDIR}/print/gsfonts
+RUN_DEPENDS= mftrace:${PORTSDIR}/print/mftrace \
+ ${LOCALBASE}/lib/X11/fonts/dejavu/DejaVuSans-Bold.ttf:${PORTSDIR}/x11-fonts/dejavu
+
LIB_DEPENDS= libguile.so:${PORTSDIR}/lang/guile \
libgmp.so:${PORTSDIR}/math/gmp \
libfreetype.so:${PORTSDIR}/print/freetype2
-RUN_DEPENDS= mftrace:${PORTSDIR}/print/mftrace \
- convert:${PORTSDIR}/graphics/ImageMagick \
- ${LOCALBASE}/lib/X11/fonts/dejavu/DejaVuSans-Bold.ttf:${PORTSDIR}/x11-fonts/dejavu
-
-INFO= lilypond-notation \
- lilypond-usage \
- lilypond-internals \
- lilypond-learning \
+INFO= internals \
lilypond-changes \
lilypond-contributor \
lilypond-essay \
lilypond-extending \
- lilypond-snippets \
+ lilypond-internals \
+ lilypond-learning \
+ lilypond-notation \
+ lilypond-usage \
lilypond-web \
- music-glossary \
- internals
+ music-glossary
-USES= bison gettext gmake pkgconfig perl5
+USES= bison:build gettext gmake pkgconfig perl5
USE_GHOSTSCRIPT=9
-USE_PYTHON= 2
-USE_PERL5= build
USE_TEX= latex
+USE_PYTHON= -3
+USE_PERL5= build
USE_GNOME= pango
MAKEFILE= GNUmakefile
@@ -54,13 +55,14 @@ GNU_MAKEFILE= yes
MAKE_JOBS_UNSAFE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-ncsb-dir=${LOCALBASE}/share/ghostscript/fonts
+CONFIGURE_ARGS+=--with-ncsb-dir=${LOCALBASE}/share/ghostscript/fonts \
+ --with-python-include=${PYTHON_INCLUDEDIR}
CONFIGURE_ENV+= ac_cv_prog_MAKEINFO="${LOCALBASE}/bin/makeinfo" \
FLEX=${FLEX} YACC=${YACC}
ALL_TARGET= all
-NOCCACHE= yes
+NO_CCACHE= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}