aboutsummaryrefslogtreecommitdiff
path: root/print/lyx15/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/lyx15/Makefile')
-rw-r--r--print/lyx15/Makefile59
1 files changed, 35 insertions, 24 deletions
diff --git a/print/lyx15/Makefile b/print/lyx15/Makefile
index 08be942e5e8b..d042c47f05ed 100644
--- a/print/lyx15/Makefile
+++ b/print/lyx15/Makefile
@@ -6,47 +6,58 @@
#
PORTNAME= lyx
-PORTVERSION= 1.1.6.4
-PORTREVISION= 1
+PORTVERSION= 1.2.0
CATEGORIES= print
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/ \
ftp://ftp.sdsc.edu/pub/other/lyx/stable/ \
ftp://gd.tuwien.ac.at/publishing/tex/lyx/stable/
-DISTNAME= lyx-1.1.6
-
-PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= patch-1.1.6fix1.gz patch-1.1.6fix2.gz patch-1.1.6fix3.gz \
- patch-1.1.6fix4.gz
-PATCH_DIST_STRIP= -p1
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX
-RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
+ latex:${PORTSDIR}/print/teTeX
+LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext \
+ forms.1:${PORTSDIR}/x11-toolkits/xforms
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.if defined(WITH_ASPELL)
+LIB_DEPENDS+= aspell.11:${PORTSDIR}/textproc/aspell
+CONFIGURE_ARGS+=--with-pspell
+.endif
+
.if defined(WITH_ISPELL)
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
-LIB_DEPENDS= forms.1:${PORTSDIR}/x11-toolkits/xforms \
- intl.2:${PORTSDIR}/devel/gettext
+
+pre-everything::
+.if !defined(WITH_ASPELL) && !defined(WITH_ISPELL)
+ #
+ # If you want to compile with Aspell/Pspell or Ispell support,
+ # hit Ctrl-C right now and use
+ # "make WITH_ASPELL=yes"
+ # or
+ # "make WITH_ISPELL=yes"
+ #
+.endif
USE_GMAKE= yes
-USE_AUTOCONF= yes
USE_XPM= yes
-USE_NEWGCC= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
USE_PERL5= yes
-USE_LIBTOOL= yes
+USE_AUTOMAKE_VER=15
+AUTOMAKE= ${WRKSRC}/autogen.sh
+AUTOCONF= ${TRUE}
CONFIGURE_ARGS= --with-extra-lib="${X11BASE}/lib ${LOCALBASE}/lib" \
- --with-extra-inc="${X11BASE}/include ${LOCALBASE}/include"
+ --with-extra-inc="${X11BASE}/include/X11 ${X11BASE}/include \
+ ${LOCALBASE}/include"
+CONFIGURE_ENV+= LDFLAGS="-L${X11BASE}/lib -lXpm -lX11"
MAN1= lyx.1 reLyX.1
-.if !defined(WITH_ISPELL)
-pre-fetch:
- @${ECHO_MSG} "If you want this port built with spell checker support, use"
- @${ECHO_MSG} "make WITH_ISPELL=yes"
-.endif
-
post-patch:
- (cd ${WRKSRC}; ${TOUCH} Makefile.in */Makefile.in src/config.h.in)
- (cd ${WRKSRC}/lib/doc; ${RM} -f *.orig)
+ @${FIND} ${WRKSRC} -name "configure.in" | ${XARGS} ${REINPLACE_CMD} \
+ -e 's|-lxforms|-lforms|g' \
+ -e 's|AC_CHECK_LIB(c,|AC_CHECK_FUNC(|g' \
+ -e 's|^INSTALL_SCRIPT=|#INSTALL_SCRIPT=|g'
.include <bsd.port.mk>