aboutsummaryrefslogtreecommitdiff
path: root/print/lyx16/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/lyx16/Makefile')
-rw-r--r--print/lyx16/Makefile88
1 files changed, 0 insertions, 88 deletions
diff --git a/print/lyx16/Makefile b/print/lyx16/Makefile
deleted file mode 100644
index 0e13075cd42e..000000000000
--- a/print/lyx16/Makefile
+++ /dev/null
@@ -1,88 +0,0 @@
-# New ports collection makefile for: lyx
-# Date created: Sa 12 Okt 1996 19:20:51 MET DST
-# Whom: Andreas Klemm <andreas@klemm.gtn.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= lyx
-PORTVERSION= 1.3.7
-CATEGORIES= print
-MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/ \
- ftp://planetmirror.com/pub/lyx/stable/ \
- http://www-ftp.lip6.fr/ftp/pub/lyx/stable/ \
- ftp://gd.tuwien.ac.at/publishing/tex/lyx/stable/
-
-MAINTAINER= mi@aldan.algebra.com
-COMMENT= Document processor interfaced with LaTeX (nearly WYSIWYG)
-
-BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
- latex:${PORTSDIR}/print/teTeX
-RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
- latex:${PORTSDIR}/print/teTeX
-
-CONFLICTS= cjk-lyx-*
-
-OPTIONS= QT "Use Qt (instead of XForms)" ${QT_PRESENT} \
- ASPELL "Utilize ASPELL library" on \
- ISPELL "Depend on ISPELL as well" off
-USE_BZIP2= yes
-USE_GNOME= gnometarget lthack
-USE_PERL5= yes
-USE_PYTHON= yes
-USE_GETTEXT= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-EXTRACT_AFTER_ARGS=| ${TAR} -xf - --exclude ${PORTNAME}-${PORTVERSION}/intl/*.[ch]
-CONFIGURE_ARGS= --with-extra-lib="${LOCALBASE}/lib" \
- --with-extra-inc="${LOCALBASE}/include"
-MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
- AUTOHEADER="${TRUE}"
-MAN1= lyx.1 reLyX.1
-USE_REINPLACE= yes
-
-post-configure:
- # Removing explicit linking with -lc
- ${REINPLACE_CMD} -e 's,-lc ,,' ${WRKSRC}/*/Makefile
-
-.include <bsd.port.pre.mk>
-
-.if exists(${X11BASE}/bin/makepsres)
-PLIST_SUB+= PSRES=
-.else
-PLIST_SUB+= PSRES='@comment '
-.endif
-
-.if defined(WITH_QT)
-LIB_DEPENDS+= qt-mt:${PORTSDIR}/x11-toolkits/qt33
-CONFIGURE_ARGS+= --with-frontend=qt
-CFLAGS+= ${PTHREAD_CFLAGS}
-CONFIGURE_ENV+= LDFLAGS=${PTHREAD_LIBS}
-RUN_DEPENDS+= ${X11BASE}/lib/X11/fonts/texcm-ttf/cmex10.ttf:${PORTSDIR}/x11-fonts/texcm-ttf
-.else
-LIB_DEPENDS+= forms:${PORTSDIR}/x11-toolkits/xforms
-USE_XPM= yes
-.endif
-
-.if defined(WITH_ASPELL)
-LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
-CONFIGURE_ARGS+= --with-pspell \
- --with-pspell-lib="${LOCALBASE}/lib" \
- --with-pspell-include="${LOCALBASE}/include"
-.endif
-
-.if defined(WITH_ISPELL)
-RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
-.endif
-
-.if exists(${X11BASE}/lib/libqt-mt.prl)
-QT_PRESENT= on
-.else
-QT_PRESENT= off
-.endif
-
-.if ${OSVERSION} < 500035
-CFLAGS+= -Wno-non-template-friend -ftemplate-depth-30
-.endif
-
-.include <bsd.port.post.mk>