aboutsummaryrefslogtreecommitdiff
path: root/print/p5-GnomePrint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/p5-GnomePrint/Makefile')
-rw-r--r--print/p5-GnomePrint/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/print/p5-GnomePrint/Makefile b/print/p5-GnomePrint/Makefile
new file mode 100644
index 000000000000..788bf2fbec36
--- /dev/null
+++ b/print/p5-GnomePrint/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-GnomePrint
+# Date created: 11 March 2001
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= GnomePrint
+PORTVERSION= 0.7005
+CATEGORIES= print lang perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Gtk
+PKGNAMEPREFIX= p5-
+DISTNAME= Gtk-Perl-${PORTVERSION}
+
+MAINTAINER= vanilla@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Gnome.pm:${PORTSDIR}/x11-toolkits/p5-Gnome \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Gtk/Gdk/Pixbuf.pm:${PORTSDIR}/x11-toolkits/p5-GdkPixbuf
+LIB_DEPENDS= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf \
+ gnomeprint.13:${PORTSDIR}/print/gnomeprint
+
+USE_GNOME= yes
+PERL_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
+
+.include <bsd.port.mk>