aboutsummaryrefslogtreecommitdiff
path: root/print/preview-latex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/preview-latex/Makefile')
-rw-r--r--print/preview-latex/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/print/preview-latex/Makefile b/print/preview-latex/Makefile
new file mode 100644
index 000000000000..49668d9c29a0
--- /dev/null
+++ b/print/preview-latex/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: preview-latex (for emacs21)
+# Date Created: 27 Jan 2002
+# Whom: Yoichi NAKAYAMA <yoichi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= preview-latex
+PORTVERSION= 0.5.8.2
+CATEGORIES= print elisp
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+
+MAINTAINER= yoichi@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/${EMACS_SITE_LISPDIR}/auctex/latex.el:${PORTSDIR}/print/auctex \
+ gs:${PORTSDIR}/print/ghostscript-gnu
+RUN_DEPENDS= ${LOCALBASE}/${EMACS_SITE_LISPDIR}/auctex/latex.el:${PORTSDIR}/print/auctex \
+ gs:${PORTSDIR}/print/ghostscript-gnu
+
+EMACS_PORT_NAME?= emacs21
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --with-emacs=${EMACS_CMD} \
+ --with-lispdir=${PREFIX}/${EMACS_VERSION_SITE_LISPDIR} \
+ --with-texmf=${PREFIX}/share/texmf
+
+DOCS= ChangeLog INSTALL PROBLEMS README README-preview RELEASE TODO
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>