aboutsummaryrefslogtreecommitdiff
path: root/print/py-cups/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/py-cups/Makefile')
-rw-r--r--print/py-cups/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/print/py-cups/Makefile b/print/py-cups/Makefile
index 9bc34e4975f6..68fa92a89d4b 100644
--- a/print/py-cups/Makefile
+++ b/print/py-cups/Makefile
@@ -23,11 +23,16 @@ USE_PYTHON= -2.7
PLIST_FILES= %%PYTHON_SITELIBDIR%%/cups.so
PYDISTUTILS_EGGINFO= py${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg-info
+.include <bsd.port.pre.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|^\(VERSION=\).*$$|\1${PORTVERSION}|' ${WRKSRC}/Makefile
+.if empty(ICONV_LIB)
+ @${REINPLACE_CMD} -e 's| or sys.platform.startswith("freebsd"):|:|' ${WRKSRC}/setup.py
+.endif
pre-configure:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/cupsconnection.c
@${REINPLACE_CMD} -e 's|#ifdef __SVR4|#ifdef __FreeBSD__|' ${WRKSRC}/cupsppd.c
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>