aboutsummaryrefslogtreecommitdiff
path: root/print/py-reportlab/files/patch-lib::setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'print/py-reportlab/files/patch-lib::setup.py')
-rw-r--r--print/py-reportlab/files/patch-lib::setup.py33
1 files changed, 33 insertions, 0 deletions
diff --git a/print/py-reportlab/files/patch-lib::setup.py b/print/py-reportlab/files/patch-lib::setup.py
new file mode 100644
index 000000000000..c7a3ddb4b57b
--- /dev/null
+++ b/print/py-reportlab/files/patch-lib::setup.py
@@ -0,0 +1,33 @@
+--- lib/setup.py.orig Fri Jan 4 08:08:55 2002
++++ lib/setup.py Fri Jan 4 08:11:04 2002
+@@ -18,23 +18,23 @@
+ author = "Robin Becker",
+ author_email = "robin@reportlab.com",
+ url = "http://www.reportlab.com",
+- packages = [],
+- ext_modules = [Extension( '_rl_accel',
+- ['_rl_accel.c'],
++ packages = ['reportlab'],
++ ext_modules = [Extension( 'reportlab.lib._rl_accel',
++ ['reportlab/lib/_rl_accel.c'],
+ include_dirs=[],
+ define_macros=[],
+ library_dirs=[],
+ libraries=LIBS, # libraries to link against
+ ),
+- Extension( 'sgmlop',
+- ['sgmlop.c'],
++ Extension( 'reportlab.lib.sgmlop',
++ ['reportlab/lib/sgmlop.c'],
+ include_dirs=[],
+ define_macros=[],
+ library_dirs=[],
+ libraries=LIBS, # libraries to link against
+ ),
+- Extension( 'pyHnj',
+- ['pyHnjmodule.c','hyphen.c', 'hnjalloc.c'],
++ Extension( 'reportlab.lib.pyHnj',
++ ['reportlab/lib/pyHnjmodule.c','reportlab/lib/hyphen.c', 'reportlab/lib/hnjalloc.c'],
+ include_dirs=[],
+ define_macros=[],
+ library_dirs=[],