aboutsummaryrefslogtreecommitdiff
path: root/print/scribus-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/scribus-devel/Makefile')
-rw-r--r--print/scribus-devel/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/print/scribus-devel/Makefile b/print/scribus-devel/Makefile
index b54f6bd15c20..2c6e414f68a6 100644
--- a/print/scribus-devel/Makefile
+++ b/print/scribus-devel/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= scribus
-PORTVERSION= 1.3.3.2
+PORTVERSION= 1.3.3.4
CATEGORIES= print editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.scribus.net/downloads/${PORTVERSION}/
@@ -32,6 +32,7 @@ USE_PYTHON= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
+USE_LDCONFIG= yes
PLIST_SUB+= SCRIBUS_VERSION=${PORTVERSION}
MAN1= scribus.1
@@ -43,6 +44,10 @@ MANLANG= "" pl
CXXFLAGS+= -fpermissive
.endif
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on 4.x
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g; \
s|-O2 ||g ; \