aboutsummaryrefslogtreecommitdiff
path: root/print/scribus/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/scribus/Makefile')
-rw-r--r--print/scribus/Makefile24
1 files changed, 16 insertions, 8 deletions
diff --git a/print/scribus/Makefile b/print/scribus/Makefile
index 2eede24dc051..6b6064c406ec 100644
--- a/print/scribus/Makefile
+++ b/print/scribus/Makefile
@@ -7,18 +7,26 @@
#
PORTNAME= scribus
-PORTVERSION= 0.6
-CATEGORIES= print
+PORTVERSION= 0.8
+PORTREVISION= 0
+CATEGORIES= print editors
MASTER_SITES= http://web2.altmuehlnet.de/fschmid/
+DIST_SUBDIR= ${PORTNAME}
+PATCH_SITES= ${MASTER_SITES}
+PATCHFILES= Fonts.diff Palette.diff
+PATCH_DIST_STRIP= -p1
MAINTAINER= ports@geeksrus.net
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu
+RUN_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu
+#LIB_DEPENDS+= lcms.1:${PORTSDIR}/graphics/lcms # needs 1.0.9
-USE_QT_VER= 2
-USE_XLIB= yes
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
+USE_QT_VER= 3
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+#USE_AUTOMAKE_VER= 14
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/share/scribus/libs \
@@ -30,7 +38,7 @@ post-patch:
${WRKSRC}/scribus/Makefile.in
.endif
@${FIND} ${WRKSRC} -type f | \
- ${XARGS} -n 10 ${REINPLACE_CMD} \
+ ${XARGS} ${REINPLACE_CMD} \
-e 's|share/scribus/doc|share/doc/scribus|'
.include <bsd.port.mk>