aboutsummaryrefslogtreecommitdiff
path: root/print/system-config-printer-kde/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/system-config-printer-kde/Makefile')
-rw-r--r--print/system-config-printer-kde/Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/print/system-config-printer-kde/Makefile b/print/system-config-printer-kde/Makefile
index 9f614a3ab8df..4b7097329c18 100644
--- a/print/system-config-printer-kde/Makefile
+++ b/print/system-config-printer-kde/Makefile
@@ -7,7 +7,6 @@
PORTNAME= system-config-printer-kde
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 3
CATEGORIES= print kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
@@ -17,25 +16,21 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE4 frontend for system-config-printer
-BUILD_DEPENDS= system-config-printer:${PORTSDIR}/print/system-config-printer \
- ${PYTHON_SITELIBDIR}/cups.so:${PORTSDIR}/print/py-cups \
- ${PYTHON_KDE4PREFIX_SITELIBDIR}/PyKDE4/kdeui.so:${PORTSDIR}/devel/kdebindings4-python-pykde4
-RUN_DEPENDS:= ${BUILD_DEPENDS} \
- ${PYTHON_SITELIBDIR}/dbus/mainloop/qt.so:${PORTSDIR}/devel/py-qt4-dbus
+RUN_DEPENDS= system-config-printer:${PORTSDIR}/print/system-config-printer \
+ ${PYTHON_SITELIBDIR}/cups.so:${PORTSDIR}/print/py-cups
USE_BZIP2= yes
USE_CMAKE= yes
-USE_KDE4= kdeprefix pimlibs automoc4
+USE_KDE4= kdeprefix pimlibs automoc4 pykde4
USE_QT_VER= 4
QT_COMPONENTS= qmake_build moc_build uic_build rcc_build
USE_PYTHON= 2.5+
MD5_FILE= ${PORTSDIR}/sysutils/kdeadmin4/distinfo
+CMAKE_ARGS+= -DINSTALL_SYSTEM_CONFIG_PRINTER:BOOL=On
BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-PYTHON_KDE4PREFIX_SITELIBDIR= ${PYTHON_SITELIBDIR:S;${PYTHONBASE};${KDE4_PREFIX};}
-
post-patch:
cd ${BUILD_WRKSRC} && ${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g' \
system-config-printer-kde.py \