aboutsummaryrefslogtreecommitdiff
path: root/print/tex-ptexenc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/tex-ptexenc/Makefile')
-rw-r--r--print/tex-ptexenc/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/print/tex-ptexenc/Makefile b/print/tex-ptexenc/Makefile
new file mode 100644
index 000000000000..7f33af3b0d67
--- /dev/null
+++ b/print/tex-ptexenc/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= ptexenc
+PORTVERSION= 1.3.0
+CATEGORIES= print
+MASTER_SITES= ftp://tug.org/historic/systems/texlive/2012/
+PKGNAMEPREFIX= tex-
+DISTNAME= texlive-20120701-source
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Library for Japanese pTeX and its tools
+
+USE_XZ= yes
+USE_TEX= kpathsea
+USE_AUTOTOOLS= libtool
+USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/texk/ptexenc
+EXTRACT_AFTER_ARGS= ${EXTRACT_FILES}
+EXTRACT_FILES= ${DISTNAME}/build-aux \
+ ${DISTNAME}/texk/ptexenc
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-system-kpathsea \
+ --with-kpathsea-includes=${LOCALBASE}/include \
+ --with-kpathsea-libdir=${LOCALBASE}/lib
+MAKE_JOBS_SAFE= yes
+
+.include <bsd.port.mk>