aboutsummaryrefslogtreecommitdiff
path: root/print/tex-xetex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/tex-xetex/Makefile')
-rw-r--r--print/tex-xetex/Makefile49
1 files changed, 24 insertions, 25 deletions
diff --git a/print/tex-xetex/Makefile b/print/tex-xetex/Makefile
index aa5324161b45..3564821d080b 100644
--- a/print/tex-xetex/Makefile
+++ b/print/tex-xetex/Makefile
@@ -1,16 +1,15 @@
# $FreeBSD$
PORTNAME= xetex
-PORTVERSION= 0.99991
-PORTREVISION= 4
+PORTVERSION= 0.99992
CATEGORIES= print
-MASTER_SITES= ftp://tug.org/historic/systems/texlive/2014/
+MASTER_SITES= ftp://tug.org/historic/systems/texlive/2015/
PKGNAMEPREFIX= tex-
-DISTNAME= texlive-${DISTVERSION_TEXMF}-source
+DISTNAME= texlive-${DISTVERSION_TEXLIVE_SOURCE}-source
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
${DISTNAME_TEXMF}${EXTRACT_SUFX}
DIST_SUBDIR= TeX
-EXTRACT_ONLY= texlive-${DISTVERSION_TEXMF}-source${EXTRACT_SUFX}
+EXTRACT_ONLY= texlive-${DISTVERSION_TEXLIVE_SOURCE}-source${EXTRACT_SUFX}
MAINTAINER= hrs@FreeBSD.org
COMMENT= TeX System with Unicode and Modern Font Technologies
@@ -18,26 +17,29 @@ COMMENT= TeX System with Unicode and Modern Font Technologies
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
libgraphite2.so:${PORTSDIR}/graphics/graphite2 \
libicuio.so:${PORTSDIR}/devel/icu \
+ libharfbuzz.so:${PORTSDIR}/print/harfbuzz \
libopenjpeg.so:${PORTSDIR}/graphics/openjpeg15 \
libpng.so:${PORTSDIR}/graphics/png \
libpoppler.so:${PORTSDIR}/graphics/poppler \
libTECkit.so:${PORTSDIR}/textproc/teckit \
libzzip.so:${PORTSDIR}/devel/zziplib
-USE_TEX= kpathsea web2c texmf formats fmtutil
USES= pkgconfig gmake tar:xz
+USE_TEX= kpathsea web2c texmf formats fmtutil
+USE_XORG= pixman
+USE_GNOME= cairo
+TEXHASHDIRS= ${TEXMFDISTDIR} ${TEXMFVARDIR}
EXTRACT_AFTER_ARGS= ${EXTRACT_FILES:S,^,${DISTNAME}/,}
-EXTRACT_FILES= \
- build-aux \
- libs/xpdf \
- libs/harfbuzz \
- texk/web2c
+EXTRACT_FILES= build-aux \
+ libs/xpdf \
+ texk/web2c
EXTRACT_AFTER_ARGS_TEXMF= \
| ${TAR} -xf - -C ${STAGEDIR}${PREFIX}/share \
--strip-components 1 --no-same-permission --no-same-owner \
${EXTRACT_FILES_TEXMF:S,^,${DISTNAME_TEXMF}/,}
-DISTVERSION_TEXMF=20140525
-DISTNAME_TEXMF= texlive-${DISTVERSION_TEXMF}-texmf
+DISTVERSION_TEXLIVE_SOURCE=20150521
+DISTVERSION_TEXLIVE_TEXMF=20150523
+DISTNAME_TEXMF= texlive-${DISTVERSION_TEXLIVE_TEXMF}-texmf
EXTRACT_FILES_TEXMF= \
texmf-dist/doc/xelatex \
texmf-dist/doc/xetex \
@@ -52,7 +54,7 @@ EXTRACT_FILES_TEXMF= \
WRKSRC= ${WRKDIR}/${DISTNAME}/texk/web2c
GNU_CONFIGURE= yes
EXCLUDE_ENGINES=aleph etex pdftex luatex luajittex mf mf-nowin mp ptex eptex \
- uptex euptex tex
+ uptex euptex tex synctex
CONFIGURE_ARGS= ${EXCLUDE_ENGINES:S/^/--disable-/} \
--enable-xetex \
--enable-web2c \
@@ -63,22 +65,19 @@ CONFIGURE_ARGS= ${EXCLUDE_ENGINES:S/^/--disable-/} \
--with-system-graphite2 \
--with-graphite2-includes=${LOCALBASE}/include/graphite2 \
--with-graphite2-libdir=${LOCALBASE}/lib \
- --with-system-icu \
- --with-icu-include=${LOCALBASE}/include \
- --with-icu-libdir=${LOCALBASE}/lib \
- --with-system-kpathsea \
- --with-kpathsea-includes=${LOCALBASE}/include \
- --with-kpathsea-libdir=${LOCALBASE}/lib \
- --with-system-libpng \
- --with-libpng-includes=${LOCALBASE}/include \
- --with-libpng-libdir=${LOCALBASE}/lib \
+ --with-system-harfbuzz \
--with-system-poppler \
--with-system-teckit \
--with-teckit-includes=${LOCALBASE}/include/teckit \
--with-teckit-libdir=${LOCALBASE}/lib \
--with-system-zziplib \
--with-system-zlib
-CFLAGS+= -I${LOCALBASE}/include
+.for L in cairo gmp kpathsea libpng mpfr pixman ptexenc icu
+CONFIGURE_ARGS+=--with-system-$L \
+ --with-$L-include=${LOCALBASE}/include \
+ --with-$L-libdir=${LOCALBASE}/lib
+.endfor
+CPPFLAGS+= -I${LOCALBASE}/include/harfbuzz -I${LOCALBASE}/include
MAKE_JOBS_UNSAFE= yes
TEX_FORMATS= xetex
@@ -90,7 +89,7 @@ pre-configure:
pre-install:
${MKDIR} ${STAGEDIR}${PREFIX}/share
- ${CAT} ${DISTDIR}/${DIST_SUBDIR}/texlive-${DISTVERSION_TEXMF}-texmf${EXTRACT_SUFX} \
+ ${CAT} ${DISTDIR}/${DIST_SUBDIR}/texlive-${DISTVERSION_TEXLIVE_TEXMF}-texmf${EXTRACT_SUFX} \
${EXTRACT_AFTER_ARGS_TEXMF}
.include <bsd.port.mk>