aboutsummaryrefslogtreecommitdiff
path: root/print/tipograf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/tipograf/Makefile')
-rw-r--r--print/tipograf/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/print/tipograf/Makefile b/print/tipograf/Makefile
index de1936b729db..b572ab827667 100644
--- a/print/tipograf/Makefile
+++ b/print/tipograf/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= tipograf
-PORTVERSION= 0.4
-PORTREVISION= 1
+PORTVERSION= 0.5
CATEGORIES= print
MASTER_SITES= http://www.falk-henrich.de/download/
@@ -18,19 +17,18 @@ COMMENT= GUI for a2ps
BUILD_DEPENDS= a2ps:${PORTSDIR}/print/a2ps-letter
RUN_DEPENDS= a2ps:${PORTSDIR}/print/a2ps-letter
-USE_REINPLACE= yes
USE_QT_VER= 3
+USE_REINPLACE= yes
+USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-qt-dir=${QT_PREFIX}
-USE_GMAKE= yes
-post-extract:
- @(cd ${WRKSRC}/src && ${TOUCH} *.ui)
+QTCPPFLAGS+= ${PTHREAD_CFLAGS}
+QTCFGLIBS+= ${PTHREAD_LIBS}
post-patch:
- @${REINPLACE_CMD} -e "s|-lqt|-lqt-mt|g" \
- -e "s|qt.so.3|qt-mt.so.3|g" \
- -e "s|qt.so|qt-mt.so|g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|-Wall -O0|@CXXFLAGS@|g' ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>