aboutsummaryrefslogtreecommitdiff
path: root/print/transfig
diff options
context:
space:
mode:
Diffstat (limited to 'print/transfig')
-rw-r--r--print/transfig/Makefile4
-rw-r--r--print/transfig/files/patch-fig2dev_dev_readpng.c19
2 files changed, 22 insertions, 1 deletions
diff --git a/print/transfig/Makefile b/print/transfig/Makefile
index 6570fe42c7c7..1dbda7b715da 100644
--- a/print/transfig/Makefile
+++ b/print/transfig/Makefile
@@ -7,6 +7,7 @@
PORTNAME= transfig
PORTVERSION= 3.2.5d
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= SF/mcj/mcj_dist_src/3.0/
DISTNAME= ${PORTNAME}.${PORTVERSION}
@@ -15,13 +16,14 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Tools to convert Xfig's .fig files
RUN_DEPENDS= ppmtogif:${PORTSDIR}/graphics/netpbm
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
USE_GHOSTSCRIPT_RUN= yes
USE_IMAKE= yes
USE_XORG= xpm
MAN1= fig2dev.1 fig2ps2tex.1 pic2tpic.1 transfig.1
+CFLAGS+= -I${LOCALBASE}/include/libpng15
MAKE_ARGS+= INSTALLFLAGS="${COPY}" \
INSTPGMFLAGS="${STRIP} ${_BINOWNGRP} -m ${BINMODE}" \
INSTBINFLAGS="${_BINOWNGRP} -m ${BINMODE}" \
diff --git a/print/transfig/files/patch-fig2dev_dev_readpng.c b/print/transfig/files/patch-fig2dev_dev_readpng.c
new file mode 100644
index 000000000000..79d259209a20
--- /dev/null
+++ b/print/transfig/files/patch-fig2dev_dev_readpng.c
@@ -0,0 +1,19 @@
+--- fig2dev/dev/readpng.c.orig 2010-04-21 18:02:14.000000000 +0200
++++ fig2dev/dev/readpng.c 2012-05-05 13:20:54.000000000 +0200
+@@ -16,6 +16,7 @@
+ #include "fig2dev.h"
+ #include "object.h"
+ #include <png.h>
++#include <pngpriv.h>
+
+ /* return codes: 1 : success
+ 0 : invalid file
+@@ -62,7 +63,7 @@
+ }
+
+ /* set long jump here */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* if we get here there was a problem reading the file */
+ png_destroy_read_struct(&png_ptr, &info_ptr, &end_info);
+ return 0;