aboutsummaryrefslogtreecommitdiff
path: root/print/xdvi
diff options
context:
space:
mode:
Diffstat (limited to 'print/xdvi')
-rw-r--r--print/xdvi/Makefile22
-rw-r--r--print/xdvi/pkg-comment1
-rw-r--r--print/xdvi/pkg-descr9
-rw-r--r--print/xdvi/pkg-plist7
-rw-r--r--print/xdvi/scripts/configure46
5 files changed, 85 insertions, 0 deletions
diff --git a/print/xdvi/Makefile b/print/xdvi/Makefile
new file mode 100644
index 000000000000..1ada50b4a504
--- /dev/null
+++ b/print/xdvi/Makefile
@@ -0,0 +1,22 @@
+DISTFILES= xdvi.tar.Z
+DISTNAME= xdvi
+MASTER_SITES= ftp://ftp.x.org/contrib/applications/
+USE_IMAKE= yes
+USE_GMAKE= yes
+
+DEST=/usr/local
+
+#gnu make required for 'make Makefiles'
+MAKE= ${GMAKE}
+
+install:
+ @echo "===> Installing for ${DISTNAME}"
+ @mkdir -p /usr/local/man/man1
+ @mkdir -p /usr/local/bin
+ @(cd ${WRKSRC}; ${GMAKE} install.man \
+ MANDIR=${DEST}/man/man1 MANSUFFIX=1)
+ @(cd ${WRKSRC}; ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} xdvi.man)
+ @(cd ${WRKSRC}; ${GMAKE} -f Makefile install BINDIR=${DEST}/bin)
+ @(cd ${WRKSRC}; install -c -m 755 -o bin MakeTeXPK ${DEST}/bin)
+
+.include <bsd.port.mk>
diff --git a/print/xdvi/pkg-comment b/print/xdvi/pkg-comment
new file mode 100644
index 000000000000..b4505832abc9
--- /dev/null
+++ b/print/xdvi/pkg-comment
@@ -0,0 +1 @@
+xdvi: a DVI Previewer for the X Window System. Patchlevel 18
diff --git a/print/xdvi/pkg-descr b/print/xdvi/pkg-descr
new file mode 100644
index 000000000000..9b0d5365d536
--- /dev/null
+++ b/print/xdvi/pkg-descr
@@ -0,0 +1,9 @@
+xdvi is a program which runs under the X window system. It is used to
+preview files, such as are produced by TeX. This program has the
+capability of showing the file shrunken by various (integer) factors,
+and also has a ``magnifying glass'' which allows one to see a small
+part of the unshrunk image momentarily. In addition to using
+keystrokes to move within the file, xdvi provides buttons on the right
+side of the window, which are synonymous with various sequences of
+keystrokes. xdvi is also able to show PostScript<tm> specials if
+Ghostscript is installed on your system.
diff --git a/print/xdvi/pkg-plist b/print/xdvi/pkg-plist
new file mode 100644
index 000000000000..d17bb066d6c1
--- /dev/null
+++ b/print/xdvi/pkg-plist
@@ -0,0 +1,7 @@
+@cd /usr/local
+@owner bin
+@mode 644
+man/man1/xdvi.1
+@mode 755
+bin/xdvi
+bin/MakeTeXPK
diff --git a/print/xdvi/scripts/configure b/print/xdvi/scripts/configure
new file mode 100644
index 000000000000..8a19b3a88239
--- /dev/null
+++ b/print/xdvi/scripts/configure
@@ -0,0 +1,46 @@
+#!/bin/sh
+
+if [ $# != 3 ]; then exit 1; fi
+
+SRCDIR=$3
+
+# paper size, default is no nor A4
+A4=n
+#default font cache directory: must be world writable
+CACHE=/tmp
+
+
+if [ ! -f $SRCDIR/MakeTeXPK.orig ]; then
+ mv $SRCDIR/MakeTeXPK $SRCDIR/MakeTeXPK.orig || exit 1
+fi
+#find the resolutions
+RES=`awk '{if(/test $BDPI/) printf "%s ",$5}' < $SRCDIR/MakeTeXPK.orig`
+# and the corresponding modes
+MODES=`awk -F= '{if(/MODE=[a-zA-Z]/) print $2}' < $SRCDIR/MakeTeXPK.orig`
+set $MODES
+echo "I need to set the mode of our printing/output device for the resolutions"
+echo "$RES dpi. (the mode must be in your modes.mf file)"
+SUBST=
+for i in $RES; do
+ echo -n "mode for $i dpi [$1]: ";
+ read answ; if [ "$answ" = "" ]; then answ=$1; fi
+ SUBST="$SUBST -e s/MODE=$1/MODE=$answ/"
+ shift
+done
+
+echo "Choose a font cache directory for automatic font generation"
+echo -n "(this directory must be world writable) [$CACHE]: "
+read answ; if [ "$answ" != "" ]; then CACHE=$answ; fi
+
+sed -e s:/usr/lib/tex:/usr/local/lib/texmf: \
+ -e s:/LocalLibrary/Fonts/TeXFonts:$CACHE: \
+ $SUBST <$SRCDIR/MakeTeXPK.orig >$SRCDIR/MakeTeXPK
+
+
+# Imakefile
+chmod +w $SRCDIR/Imakefile
+echo "OSDEFS=" >> $SRCDIR/Imakefile || exit 1;
+echo "OPTIONDEFS=-DUSE_PK -DGREY -DPS_GS -DMAKEPK -DBUTTONS" >> $SRCDIR/Imakefile
+echo "DEFAULT_FONT_PATH=/usr/local/lib/texmf/fonts/pk:$CACHE/pk" >> $SRCDIR/Imakefile
+echo "DEFAULT_VF_PATH=/usr/local/lib/texmf/fonts/vf" >> $SRCDIR/Imakefile
+exit 0;