aboutsummaryrefslogtreecommitdiff
path: root/print/xfce4-print/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/xfce4-print/Makefile')
-rw-r--r--print/xfce4-print/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/print/xfce4-print/Makefile b/print/xfce4-print/Makefile
index 6b7ef4927a9b..61432d99f362 100644
--- a/print/xfce4-print/Makefile
+++ b/print/xfce4-print/Makefile
@@ -11,17 +11,18 @@ DISTNAME= xfprint-${PORTVERSION}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
-COMMENT= Xfce 4 graphical frontend for printing
+COMMENT= Print system support for the Xfce Desktop
-BUILD_DEPENDS+= a2ps:${PORTSDIR}/print/a2ps
-RUN_DEPENDS+= a2ps:${PORTSDIR}/print/a2ps
+LICENSE= GPLv2
+
+BUILD_DEPENDS= a2ps:${PORTSDIR}/print/a2ps
+RUN_DEPENDS= a2ps:${PORTSDIR}/print/a2ps
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
-USES= gettext pkgconfig
-USE_GMAKE= yes
-USE_GNOME= glib20 gnomehack gtk20 intltool intlhack
+USES= gettext pkgconfig gmake pathfix
+USE_GNOME= glib20 gtk20 intltool intlhack
USE_LDCONFIG= yes
USE_XFCE= configenv libgui libutil xfconf
@@ -30,14 +31,13 @@ OPTIONS_DEFAULT= LPR
OPTIONS_SINGLE= PRINTMETHOD
OPTIONS_SINGLE_PRINTMETHOD= LPR CUPS
LETTER_DESC= Use letter paper format instead of A4
-LPR_DESC= Use lpr as printing system
+LPR_DESC= LPR printing system support
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MCUPS}
CONFIGURE_ARGS+=--enable-cups
-LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-client
+LIB_DEPENDS+= libcups.so:${PORTSDIR}/print/cups-client
PLIST_SUB+= CUPS=""
.else
CONFIGURE_ARGS+=--disable-cups