aboutsummaryrefslogtreecommitdiff
path: root/print/xpp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/xpp/Makefile')
-rw-r--r--print/xpp/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/print/xpp/Makefile b/print/xpp/Makefile
index ea13555c9ea8..873d3a4d420a 100644
--- a/print/xpp/Makefile
+++ b/print/xpp/Makefile
@@ -22,7 +22,8 @@ USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-PLIST_FILES= bin/xpp
+PLIST_FILES= bin/xpp share/doc/xpp/README
+PLIST_DIRS= share/doc/xpp
post-configure:
@${REINPLACE_CMD} -e 's|$$(all_includes)|-I ${PREFIX}/include|' \
@@ -30,4 +31,8 @@ post-configure:
@${REINPLACE_CMD} -e 's|CFLAGS =|CFLAGS +=|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|printFiles::get|get|' ${WRKSRC}/xpp.h
+post-install:
+ ${MKDIR} ${PREFIX}/share/doc/xpp
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xpp
+
.include <bsd.port.mk>