aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
Diffstat (limited to 'print')
-rw-r--r--print/ghostscript8/Makefile4
-rw-r--r--print/ghostscript8/Makefile.drivers2
-rw-r--r--print/ghostscript8/files/Makefile.drivers_post4
-rw-r--r--print/ghostscript9/Makefile4
-rw-r--r--print/ghostscript9/Makefile.drivers2
-rw-r--r--print/ghostscript9/files/Makefile.drivers_post4
6 files changed, 14 insertions, 6 deletions
diff --git a/print/ghostscript8/Makefile b/print/ghostscript8/Makefile
index 45b7309abf23..359dd0c0bf68 100644
--- a/print/ghostscript8/Makefile
+++ b/print/ghostscript8/Makefile
@@ -90,8 +90,8 @@ MLINKS= gslp.1 gsbj.1 \
CIDFONTDIR= ${DATADIR}/${PORTVERSION}/Resource
EXCLUDE_DIRS= jbig2dec jpeg expat jasper libpng tiff zlib
-.include <bsd.port.pre.mk>
.include "Makefile.drivers"
+.include <bsd.port.pre.mk>
.include "${FILESDIR}/Makefile.drivers_post"
.for D in ${OPTIONS_DEFINE:MGS_*:S/^GS_//}
@@ -171,10 +171,12 @@ pre-build-drivers.mak:
.for D in ${OPTIONS_DEFINE:MGS_*:S/^GS_//}
.for N in ${DEVS_LIST}
.if ${PORT_OPTIONS:MGS_${D}}
+.if !defined(OPTIONS_UNSET) || !${OPTIONS_UNSET:MGS_${D}}
.for X in ${DEVICE_${N}:M${D}.dev}
@${ECHO_CMD} 'DEVICE_${N}+= $$(DD)${D}.dev' >> ${WRKSRC}/base/drivers.mak
.endfor
.endif
+.endif
.endfor
.endfor
diff --git a/print/ghostscript8/Makefile.drivers b/print/ghostscript8/Makefile.drivers
index a2bc5f2901f8..175e4975a4ab 100644
--- a/print/ghostscript8/Makefile.drivers
+++ b/print/ghostscript8/Makefile.drivers
@@ -13,11 +13,9 @@ OPTIONS_X11= \
GS_x11rg16x \
GS_x11rg32x
-.if ${ARCH:Mamd64} || ${ARCH:Mi386}
OPTIONS_SVGALIB= \
GS_lvga256 \
GS_vgalib
-.endif
OPTIONS_ICONV= \
GS_oprp \
diff --git a/print/ghostscript8/files/Makefile.drivers_post b/print/ghostscript8/files/Makefile.drivers_post
index 20e7a086c9f3..ee68a8ffaafd 100644
--- a/print/ghostscript8/files/Makefile.drivers_post
+++ b/print/ghostscript8/files/Makefile.drivers_post
@@ -52,7 +52,11 @@ VGA_DEVS= lvga256 vgalib
.for D in ${VGA_DEVS}
.if ${PORT_OPTIONS:MGS_${D}}
+.if ${ARCH:Mamd64} || ${ARCH:Mi386}
_VGA_DEVS+= ${D}
+.else
+OPTIONS_UNSET+= ${PORT_OPTIONS:MGS_${D}}
+.endif
.endif
.endfor
diff --git a/print/ghostscript9/Makefile b/print/ghostscript9/Makefile
index 09a0b821e3c9..aace4e710856 100644
--- a/print/ghostscript9/Makefile
+++ b/print/ghostscript9/Makefile
@@ -95,8 +95,8 @@ MLINKS= gslp.1 gsbj.1 \
EXCLUDE_DIRS= freetype jbig2dec jpeg expat jasper libpng tiff zlib
-.include <bsd.port.pre.mk>
.include "Makefile.drivers"
+.include <bsd.port.pre.mk>
.include "${FILESDIR}/Makefile.drivers_post"
.for D in ${OPTIONS_DEFINE:MGS_*:S/^GS_//}
@@ -172,10 +172,12 @@ pre-build-drivers.mak:
.for D in ${OPTIONS_DEFINE:MGS_*:S/^GS_//}
.for N in ${DEVS_LIST}
.if ${PORT_OPTIONS:MGS_${D}}
+.if !defined(OPTIONS_UNSET) || !${OPTIONS_UNSET:MGS_${D}}
.for X in ${${N:S/^/DEVICE_/:S/^DEVICE_DISPLAY_DEV/DISPLAY_DEV/}:M${D}.dev}
@${ECHO_CMD} '${N:S/^/DEVICE_/:S/^DEVICE_DISPLAY_DEV/DISPLAY_DEV/}+= $$(DD)${D}.dev' >> ${WRKSRC}/base/drivers.mak
.endfor
.endif
+.endif
.endfor
.endfor
diff --git a/print/ghostscript9/Makefile.drivers b/print/ghostscript9/Makefile.drivers
index 6a1088da34b0..5371b50ebbc4 100644
--- a/print/ghostscript9/Makefile.drivers
+++ b/print/ghostscript9/Makefile.drivers
@@ -13,11 +13,9 @@ OPTIONS_X11= \
GS_x11rg16x \
GS_x11rg32x
-.if ${ARCH:Mamd64} || ${ARCH:Mi386}
OPTIONS_SVGALIB= \
GS_lvga256 \
GS_vgalib
-.endif
OPTIONS_ICONV= \
GS_oprp \
diff --git a/print/ghostscript9/files/Makefile.drivers_post b/print/ghostscript9/files/Makefile.drivers_post
index 2f947d23ad18..09230870cc8c 100644
--- a/print/ghostscript9/files/Makefile.drivers_post
+++ b/print/ghostscript9/files/Makefile.drivers_post
@@ -52,7 +52,11 @@ VGA_DEVS= lvga256 vgalib
.for D in ${VGA_DEVS}
.if ${PORT_OPTIONS:MGS_${D}}
+.if ${ARCH:Mamd64} || ${ARCH:Mi386}
_VGA_DEVS+= ${D}
+.else
+OPTIONS_UNSET+= ${PORT_OPTIONS:MGS_${D}}
+.endif
.endif
.endfor