aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/rubygem-prawn/Makefile27
-rw-r--r--print/rubygem-prawn/distinfo3
-rw-r--r--print/rubygem-prawn/pkg-descr8
4 files changed, 39 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 23785a28ca10..bd853cb7aecb 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -295,6 +295,7 @@
SUBDIR += rubygem-color
SUBDIR += rubygem-colortools
SUBDIR += rubygem-pdfwriter
+ SUBDIR += rubygem-prawn
SUBDIR += scribus
SUBDIR += sgf2tex
SUBDIR += splix
diff --git a/print/rubygem-prawn/Makefile b/print/rubygem-prawn/Makefile
new file mode 100644
index 000000000000..307a4f76c09e
--- /dev/null
+++ b/print/rubygem-prawn/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: rubygem-prawn
+# Date created: 29 Oct 2008
+# Whom: wenheping@gmail.com
+#
+# $FreeBSD$
+
+PORTNAME= prawn
+PORTVERSION= 0.2.3
+CATEGORIES= print rubygems
+MASTER_SITES= RF/prawn
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Fast pure Ruby PDF generator
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+GEM_NAME= ${DISTNAME}
+
+post-install:
+ @${ECHO} ${GEM_CACHE} > ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},${GEM_DOC_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${ECHO} ${GEM_SPEC} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm ${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/print/rubygem-prawn/distinfo b/print/rubygem-prawn/distinfo
new file mode 100644
index 000000000000..59296cc89b7b
--- /dev/null
+++ b/print/rubygem-prawn/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/prawn-0.2.3.gem) = 54a5efeae45c0a0ad0c7435f1319a429
+SHA256 (rubygem/prawn-0.2.3.gem) = a9b5bb54c3d537ba61d2915b3213ffee1848c9f3d1096f0b8a3665f2e7ea6a14
+SIZE (rubygem/prawn-0.2.3.gem) = 3737600
diff --git a/print/rubygem-prawn/pkg-descr b/print/rubygem-prawn/pkg-descr
new file mode 100644
index 000000000000..472cbdda74c9
--- /dev/null
+++ b/print/rubygem-prawn/pkg-descr
@@ -0,0 +1,8 @@
+Prawn is a new pure Ruby PDF generation library,
+with the long term goal of providing a suitable
+replacement for PDF::Writer. It is being developed
+under the auspices of the Ruby Mendicant project
+with copious help from a number of mighty fine
+contributors.
+
+WWW: http://rubyforge.org/projects/prawn/