aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
Diffstat (limited to 'print')
-rw-r--r--print/cups-base/Makefile2
-rw-r--r--print/fontforge/Makefile3
-rw-r--r--print/gv/Makefile2
-rw-r--r--print/openprinting/Makefile3
-rw-r--r--print/pdftk/Makefile2
-rw-r--r--print/py-cups/Makefile2
-rw-r--r--print/wprint/Makefile2
7 files changed, 7 insertions, 9 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 4d83290b607e..836ccf2281ec 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -83,7 +83,7 @@ XDG_OPEN= Build with XDG_OPEN as browser
COMMENT2= Library cups
INSTALL_WRKSRC= ${WRKSRC}/cups
PLIST= ${MASTERDIR}/pkg-plist.client
-USE_ICONV= yes
+USES+= iconv
USE_LDCONFIG= yes
PKGMESSAGE= ${NONEXISTENT}
DESCR= ${MASTERDIR}/pkg-descr.client
diff --git a/print/fontforge/Makefile b/print/fontforge/Makefile
index eb7588c5bf4b..ebb4aa607724 100644
--- a/print/fontforge/Makefile
+++ b/print/fontforge/Makefile
@@ -34,10 +34,9 @@ DISTFILES+= ${DOCFILES:C/$/:docs/}
.endif
USE_BZIP2= yes
-USES= gettext
+USES= gettext iconv
USE_XORG= x11 xi ice xkbui
USE_GMAKE= yes
-USE_ICONV= yes
PATCH_STRIP= -l
.if !defined(FONTFORGE_NO_MULTILAYER)
diff --git a/print/gv/Makefile b/print/gv/Makefile
index e02e01c613c1..7d16e9173392 100644
--- a/print/gv/Makefile
+++ b/print/gv/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
USE_XORG= xpm ice sm xext xmu x11
USE_GHOSTSCRIPT= yes
USE_GMAKE= yes
-USE_ICONV= yes
+USES= iconv
USE_PERL5_BUILD= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/print/openprinting/Makefile b/print/openprinting/Makefile
index d12b6a55d764..337df19ba410 100644
--- a/print/openprinting/Makefile
+++ b/print/openprinting/Makefile
@@ -22,8 +22,7 @@ WRKSRC= ${WRKDIR}/papi-${PORTVERSION}_beta
USE_BZIP2= yes
USE_GMAKE= yes
-USES= gettext
-USE_ICONV= yes
+USES= gettext iconv
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/libexec
diff --git a/print/pdftk/Makefile b/print/pdftk/Makefile
index e6b3005a631b..524f0e023d7f 100644
--- a/print/pdftk/Makefile
+++ b/print/pdftk/Makefile
@@ -18,7 +18,7 @@ CSUFF= ${_USE_GCC:S/.//}
USE_GCC= 4.6+
USE_GMAKE= yes
-USE_ICONV= yes
+USES= iconv
USE_LDCONFIG= ${PREFIX}/lib/gcc${CSUFF}
# gcj/libgcj don't exist on some platforms
diff --git a/print/py-cups/Makefile b/print/py-cups/Makefile
index dd6e7b01e130..9bc34e4975f6 100644
--- a/print/py-cups/Makefile
+++ b/print/py-cups/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= cups:${PORTSDIR}/print/cups-client
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_BZIP2= yes
-USE_ICONV= yes
+USES= iconv
USE_PYDISTUTILS= yes
USE_PYTHON= -2.7
diff --git a/print/wprint/Makefile b/print/wprint/Makefile
index 3960f2c568e2..a9e4ee229599 100644
--- a/print/wprint/Makefile
+++ b/print/wprint/Makefile
@@ -20,7 +20,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
-USE_ICONV= yes
+USES= iconv
USE_PERL5= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes