aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
Diffstat (limited to 'print')
-rw-r--r--print/alignmargins/Makefile8
-rw-r--r--print/guitartex/Makefile9
-rw-r--r--print/hpijs/Makefile3
-rw-r--r--print/ttf2pt1/Makefile3
-rw-r--r--print/wprint/Makefile10
5 files changed, 8 insertions, 25 deletions
diff --git a/print/alignmargins/Makefile b/print/alignmargins/Makefile
index b90c6bbb6015..16ea60b2012a 100644
--- a/print/alignmargins/Makefile
+++ b/print/alignmargins/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: alignmargins
-# Date created: 2005-01-28
-# Whom: Michael Nottebrock <lofi@FreeBSD.org>
-#
+# Created by: Michael Nottebrock <lofi@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= alignmargins
PORTVERSION= 1.0
@@ -18,7 +14,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Utility script to generate custom margins in PPDs for CUPS
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
do-extract:
@${RM} -rf ${WRKDIR}
diff --git a/print/guitartex/Makefile b/print/guitartex/Makefile
index 3079b8aa3194..441b0b248442 100644
--- a/print/guitartex/Makefile
+++ b/print/guitartex/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: GuitarTeX
-# Date created: Jul 23, 2001
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= guitartex
PORTVERSION= 2.8.2
@@ -21,7 +16,7 @@ COMMENT= GuitarTeX converts the Chord format into "normal" LaTeX format
RUN_DEPENDS= p5-Tk>=0:${PORTSDIR}/x11-toolkits/p5-Tk \
latex:${PORTSDIR}/print/latex
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
do-configure:
diff --git a/print/hpijs/Makefile b/print/hpijs/Makefile
index b9cea5f24221..f4aa34ff0292 100644
--- a/print/hpijs/Makefile
+++ b/print/hpijs/Makefile
@@ -16,7 +16,6 @@ CONFLICTS= hplip-[0-9]*
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking
USE_GHOSTSCRIPT_RUN= yes
-WANT_PERL= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -31,7 +30,7 @@ FOOMATIC_DESC= Install foomatic-rip and PPD files
.if ${PORT_OPTIONS:MCUPS} || ${PORT_OPTIONS:MFOOMATIC}
CONFLICTS+= foomatic-filters-*
-USE_PERL5= true
+USES= perl5
CONFIGURE_ARGS+= --enable-foomatic-install
PLIST_SUB+= FOOMATIC=""
.else
diff --git a/print/ttf2pt1/Makefile b/print/ttf2pt1/Makefile
index 004539313a75..0aacc58fe2b3 100644
--- a/print/ttf2pt1/Makefile
+++ b/print/ttf2pt1/Makefile
@@ -14,8 +14,7 @@ COMMENT= True Type Font to Postscript Type 1 Converter
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
RUN_DEPENDS= t1asm:${PORTSDIR}/print/t1utils
-USES= pkgconfig shebangfix
-USE_PERL5= yes
+USES= pkgconfig shebangfix perl5
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} ${CPPFLAGS}" LIBS="${LDFLAGS}" \
INSTDIR="${PREFIX}" LIBXDIR="${PREFIX}/bin"
SHEBANG_FILES= app/TeX/sfd2map \
diff --git a/print/wprint/Makefile b/print/wprint/Makefile
index a9e4ee229599..836b5795fbf8 100644
--- a/print/wprint/Makefile
+++ b/print/wprint/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: wprint
-# Date created: Oct 15, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= wprint
PORTVERSION= 2.05
@@ -20,8 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
-USES= iconv
-USE_PERL5= yes
+USES= iconv perl5
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes