aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
Diffstat (limited to 'print')
-rw-r--r--print/rubygem-color/Makefile7
-rw-r--r--print/rubygem-colortools/Makefile6
-rw-r--r--print/rubygem-pdfwriter/Makefile6
3 files changed, 10 insertions, 9 deletions
diff --git a/print/rubygem-color/Makefile b/print/rubygem-color/Makefile
index b8bb80235141..3dce6bb0d2e6 100644
--- a/print/rubygem-color/Makefile
+++ b/print/rubygem-color/Makefile
@@ -18,6 +18,7 @@ BUILD_DEPENDS= rubygem-archive-tar-minitar>=0.5.1:${PORTSDIR}/archivers/rubygem-
rubygem-hoe>=1.3.0:${PORTSDIR}/devel/rubygem-hoe
RUN_DEPENDS= ${BUILD_DEPENDS}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/print/rubygem-colortools/Makefile b/print/rubygem-colortools/Makefile
index 142ece2b0383..3dac4fe36dd8 100644
--- a/print/rubygem-colortools/Makefile
+++ b/print/rubygem-colortools/Makefile
@@ -14,8 +14,8 @@ DISTNAME= color-tools-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Provides colour space definition and manpiulation
+USE_RUBY= yes
+USE_RUBYGEMS= yes
GEM_NAME= ${DISTNAME}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/rubygem-pdfwriter/Makefile b/print/rubygem-pdfwriter/Makefile
index 3ec0df1671e4..d09653146e68 100644
--- a/print/rubygem-pdfwriter/Makefile
+++ b/print/rubygem-pdfwriter/Makefile
@@ -18,8 +18,8 @@ BUILD_DEPENDS= rubygem-color>=1.4.0:${PORTSDIR}/print/rubygem-color \
rubygem-transactionsimple>=1.4.0:${PORTSDIR}/devel/rubygem-transactionsimple
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_RUBY= yes
+USE_RUBYGEMS= yes
GEM_NAME= ${DISTNAME}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>