aboutsummaryrefslogtreecommitdiff
path: root/russian/p5-XML-Parser-encodings/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'russian/p5-XML-Parser-encodings/Makefile')
-rw-r--r--russian/p5-XML-Parser-encodings/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/russian/p5-XML-Parser-encodings/Makefile b/russian/p5-XML-Parser-encodings/Makefile
index b29bc73aaf21..d84aed2b8c2e 100644
--- a/russian/p5-XML-Parser-encodings/Makefile
+++ b/russian/p5-XML-Parser-encodings/Makefile
@@ -32,18 +32,18 @@ post-extract:
.endfor
do-configure:
- @${CP} ${WRKSRC}/iconv/cp866.txt ${WRKDIR}
- @${CP} ${WRKSRC}/iconv-extra/windows-1251.txt ${WRKDIR}/cp1251.txt
- @${CP} ${WRKSRC}/iconv-extra/mac-cyrillic.txt ${WRKDIR}
- @${PERL} -pi -e 's/\r/\n/gm;' ${WRKDIR}/mac-cyrillic.txt
+ @${CP} ${WRKSRC}/iconv/cp866.txt ${WRKSRC}
+ @${CP} ${WRKSRC}/iconv-extra/windows-1251.txt ${WRKSRC}/cp1251.txt
+ @${CP} ${WRKSRC}/iconv-extra/mac-cyrillic.txt ${WRKSRC}
+ @${PERL} -pi -e 's/\r/\n/gm;' ${WRKSRC}/mac-cyrillic.txt
do-build:
.for ENC in ${RUSSIANENC}
- @${LOCALBASE}/bin/make_encmap ${ENC} ${WRKDIR}/${ENC}.txt | \
+ @${LOCALBASE}/bin/make_encmap ${ENC} ${WRKSRC}/${ENC}.txt | \
${PERL} -pi -e "s/(?<=^<encmap name='${ENC}')()(?=>)/ expat='yes'/;" \
- >${WRKDIR}/${ENC}.xml
+ >${WRKSRC}/${ENC}.xml
@${LOCALBASE}/bin/compile_encoding \
- -o ${WRKDIR}/${ENC}.enc ${WRKDIR}/${ENC}.xml
+ -o ${WRKSRC}/${ENC}.enc ${WRKSRC}/${ENC}.xml
.endfor
do-install: