aboutsummaryrefslogtreecommitdiff
path: root/russian
diff options
context:
space:
mode:
Diffstat (limited to 'russian')
-rw-r--r--russian/Makefile1
-rw-r--r--russian/nagios/Makefile75
-rw-r--r--russian/nagios/distinfo2
-rw-r--r--russian/nagios/files/patch-aa37
-rw-r--r--russian/nagios/files/patch-ab10
-rw-r--r--russian/nagios/files/patch-ad69
-rw-r--r--russian/nagios/files/patch-ae11
-rw-r--r--russian/nagios/files/patch-ag31
-rw-r--r--russian/nagios/files/patch-ai25
-rw-r--r--russian/nagios/files/patch-xcddb.c11
-rw-r--r--russian/nagios/pkg-descr3
-rw-r--r--russian/nagios/pkg-install68
-rw-r--r--russian/nagios/pkg-plist314
13 files changed, 657 insertions, 0 deletions
diff --git a/russian/Makefile b/russian/Makefile
index 766ca552adfe..e25b23ec15d6 100644
--- a/russian/Makefile
+++ b/russian/Makefile
@@ -23,6 +23,7 @@
SUBDIR += mtc
SUBDIR += mueller-dic
SUBDIR += muttprint
+ SUBDIR += nagios
SUBDIR += ooodict-ru_RU
SUBDIR += openoffice-1.0
SUBDIR += openoffice-1.1
diff --git a/russian/nagios/Makefile b/russian/nagios/Makefile
new file mode 100644
index 000000000000..33f546347410
--- /dev/null
+++ b/russian/nagios/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: nagios
+# Date created: 04 Feb 2004
+# Whom: Roman Y. Bogdanov <sam@brj.pp.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nagios
+PORTVERSION= 1.1
+CATEGORIES= russian net-mgmt
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}:main \
+ http://onix.opennet.ru/files/:ruspatch
+MASTER_SITE_SUBDIR=nagios
+DISTFILES= nagios-1.1.tar.gz:main nagios_rus_1_1.tar.gz:ruspatch
+
+MAINTAINER= sam@brj.pp.ru
+COMMENT= Extremely powerful network monitoring system with Russian language
+
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
+RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net-mgmt/nagios-plugins
+
+CONFLICTS= nagios-1*
+
+USE_GETOPT_LONG=yes
+GNU_CONFIGURE= yes
+
+CPPFLAGS= ${INCGD} -I${LOCALBASE}/include
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CFLAGS="${CPPFLAGS} ${CFLAGS} ${INCGD}" \
+ LIBS="-L${LOCALBASE}/lib ${LIBGD}"
+CONFIGURE_ARGS+= \
+ --with-command-user=nagios \
+ --with-command-grp=www \
+ --with-nagios-user=nagios \
+ --with-nagios-grp=nagios \
+ --with-template-objects \
+ --with-template-extinfo \
+ --with-init-dir=${PREFIX}/etc/rc.d \
+ --with-gd-lib=${LOCALBASE}/lib \
+ --sbindir=${PREFIX}/share/nagios/cgi-bin \
+ --libexecdir=${PREFIX}/libexec/nagios \
+ --datadir=${PREFIX}/share/nagios \
+ --sysconfdir=${PREFIX}/etc/nagios \
+ --localstatedir=/var/spool/nagios \
+
+.if defined(WITH_MYSQL)||defined(WITH_NAGMIN)
+USE_MYSQL= yes
+CONFIGURE_ARGS+= --with-mysql-lib=${LOCALBASE}/lib/mysql \
+ --with-mysql-inc=${LOCALBASE}/include/mysql \
+ --with-mysql-xdata
+.endif
+
+.if defined(NAGIOS_FILE_PERFDATA)
+CONFIGURE_ARGS+=--with-file-perfdata
+.endif
+
+.if defined(WITH_POSTGRES)
+LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
+CONFIGURE_ARGS+=--with-pgsql-lib=${LOCALBASE}/pgsql \
+ --with-pgsql-inc=${LOCALBASE}/pgsql \
+ --with-pgsql-xdata
+.endif
+
+INSTALL_TARGET= all install config install-config install-daemoninit install-commandmode
+
+pre-patch:
+ ${CP} -R ${WRKSRC}/../nagios_rus_1_1/cgi/* ${WRKSRC}/cgi/
+ ${CP} -R ${WRKSRC}/../nagios_rus_1_1/html/* ${WRKSRC}/html/
+ ${CP} -R ${WRKSRC}/../nagios_rus_1_1/html/images/* ${WRKSRC}/html/images/
+
+pre-install:
+ @PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
+.include <bsd.port.mk>
diff --git a/russian/nagios/distinfo b/russian/nagios/distinfo
new file mode 100644
index 000000000000..172e2a50e5f5
--- /dev/null
+++ b/russian/nagios/distinfo
@@ -0,0 +1,2 @@
+MD5 (nagios-1.1.tar.gz) = 5f48ecd9bad2c4d7c9d88d0b6f347ecf
+MD5 (nagios_rus_1_1.tar.gz) = 81253c03ccaa5b30059a11b9e6a707c2
diff --git a/russian/nagios/files/patch-aa b/russian/nagios/files/patch-aa
new file mode 100644
index 000000000000..595da2b80d2c
--- /dev/null
+++ b/russian/nagios/files/patch-aa
@@ -0,0 +1,37 @@
+--- Makefile.in.orig Sat Oct 26 02:47:15 2002
++++ Makefile.in Tue Nov 26 13:58:29 2002
+@@ -28,7 +28,7 @@
+ INSTALL_OPTS=@INSTALL_OPTS@
+ COMMAND_OPTS=@COMMAND_OPTS@
+ INIT_DIR=@init_dir@
+-INIT_OPTS=-o root -g root
++INIT_OPTS=-o root -g wheel
+ CGICFGDIR=$(CGIDIR)
+ PERLDIR=@PERLDIR@
+
+@@ -196,6 +196,8 @@
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/misccommands.cfg $(DESTDIR)$(CFGDIR)/misccommands.cfg-sample
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/services.cfg $(DESTDIR)$(CFGDIR)/services.cfg-sample
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/timeperiods.cfg $(DESTDIR)$(CFGDIR)/timeperiods.cfg-sample
++ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-extinfo/hostextinfo.cfg $(DESTDIR)$(CFGDIR)/hostextinfo.cfg-sample
++ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-extinfo/serviceextinfo.cfg $(DESTDIR)$(CFGDIR)/serviceextinfo.cfg-sample
+
+ @echo ""
+ @echo "*** Sample config file installed ***"
+@@ -215,7 +217,7 @@
+
+ install-daemoninit:
+ $(INSTALL) -m 755 -d $(INIT_OPTS) $(DESTDIR)$(INIT_DIR)
+- $(INSTALL) -m 774 $(INIT_OPTS) daemon-init $(DESTDIR)$(INIT_DIR)/nagios
++ $(INSTALL) -m 774 $(INIT_OPTS) daemon-init $(DESTDIR)$(INIT_DIR)/nagios.sh
+
+ @echo ""
+ @echo "*** Init script installed ***"
+@@ -238,7 +240,6 @@
+
+ install-commandmode:
+ $(INSTALL) -m 775 $(COMMAND_OPTS) -d $(DESTDIR)$(LOGDIR)/rw
+- chmod g+s $(DESTDIR)$(LOGDIR)/rw
+
+ @echo ""
+ @echo "*** External command directory configured ***"
diff --git a/russian/nagios/files/patch-ab b/russian/nagios/files/patch-ab
new file mode 100644
index 000000000000..6634c8f6b40a
--- /dev/null
+++ b/russian/nagios/files/patch-ab
@@ -0,0 +1,10 @@
+--- base/Makefile.in.orig Mon Nov 11 04:52:13 2002
++++ base/Makefile.in Tue Nov 26 13:46:41 2002
+@@ -105,7 +105,6 @@
+ devclean: clean
+
+ install:
+- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(BINDIR)
+ $(INSTALL) -m 774 $(INSTALL_OPTS) @nagios_name@ $(DESTDIR)$(BINDIR)
+ $(STRIP) $(DESTDIR)$(BINDIR)/@nagios_name@
+
diff --git a/russian/nagios/files/patch-ad b/russian/nagios/files/patch-ad
new file mode 100644
index 000000000000..10c3db33738b
--- /dev/null
+++ b/russian/nagios/files/patch-ad
@@ -0,0 +1,69 @@
+--- configure.orig Tue Jun 3 12:47:57 2003
++++ configure Thu Jul 31 16:35:45 2003
+@@ -11,7 +11,7 @@
+ ac_help=
+ ac_default_prefix=/usr/local
+ # Any additions from configure.in:
+-ac_default_prefix=/usr/local/nagios
++#ac_default_prefix=/usr/local/nagios
+ ac_help="$ac_help
+ --with-nagios-user=<user> sets user name to run nagios"
+ ac_help="$ac_help
+@@ -576,9 +576,9 @@
+ # Prefer explicitly selected file to automatically selected ones.
+ if test -z "$CONFIG_SITE"; then
+ if test "x$prefix" != xNONE; then
+- CONFIG_SITE="$prefix/share/config.site $prefix/etc/config.site"
++ CONFIG_SITE="$prefix/share/nagios/config.site $prefix/etc/nagios/config.site"
+ else
+- CONFIG_SITE="$ac_default_prefix/share/config.site $ac_default_prefix/etc/config.site"
++ CONFIG_SITE="$ac_default_prefix/share/nagios/config.site $ac_default_prefix/etc/nagios/config.site"
+ fi
+ fi
+ for ac_site_file in $CONFIG_SITE; do
+@@ -2608,6 +2608,9 @@
+ LDFLAGS="${LDFLAGS} -L${withval}"
+ LD_RUN_PATH="${withval}${LD_RUN_PATH:+:}${LD_RUN_PATH}"
+
++else
++ LDFLAGS="${LDFLAGS} -L/usr/local/lib"
++ LD_RUN_PATH="/usr/local/ib${LD_RUN_PATH:+:}${LD_RUN_PATH}"
+ fi
+
+ # Check whether --with-gd-inc or --without-gd-inc was given.
+@@ -2615,6 +2618,8 @@
+ withval="$with_gd_inc"
+
+ CFLAGS="${CFLAGS} -I${withval}"
++else
++ CFLAGS="${CFLAGS} -I/usr/local/include/gd"
+
+ fi
+
+@@ -2748,14 +2753,14 @@
+ fi
+
+ if test x$GDLIBFOUND = x; then
+- echo $ac_n "checking for gdImagePng in -lgd (order 3)""... $ac_c" 1>&6
+-echo "configure:2753: checking for gdImagePng in -lgd (order 3)" >&5
++ echo $ac_n "checking for gdImagePng in -lgd1 (order 3)""... $ac_c" 1>&6
++echo "configure:2753: checking for gdImagePng in -lgd1 (order 3)" >&5
+ ac_lib_var=`echo gd'_'gdImagePng'_'3 | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+- LIBS="-lgd -lpng -lz -lm $LIBS"
++ LIBS="-lgd1 -lz -lm -lpng -ljpeg $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 2761 "configure"
+ #include "confdefs.h"
+@@ -2785,7 +2790,7 @@
+ echo "$ac_t""yes" 1>&6
+
+ GDLIBFOUND=yep
+- GDLIBS="-lgd -lpng -lz -lm"
++ GDLIBS="-lgd1 -lz -lm -lpng"
+
+ else
+ echo "$ac_t""no" 1>&6
diff --git a/russian/nagios/files/patch-ae b/russian/nagios/files/patch-ae
new file mode 100644
index 000000000000..0bf8e064b3a7
--- /dev/null
+++ b/russian/nagios/files/patch-ae
@@ -0,0 +1,11 @@
+--- configure.in.orig Mon Apr 30 17:22:35 2001
++++ configure.in Tue May 1 19:36:54 2001
+@@ -1,7 +1,7 @@
+ dnl Process this -*-m4-*- file with autoconf to produce a configure script.
+ AC_INIT(base/nagios.c)
+ AC_CONFIG_HEADER(common/config.h common/snprintf.h base/nagios.h cgi/cgiutils.h)
+-AC_PREFIX_DEFAULT(/usr/local/nagios)
++AC_PREFIX_DEFAULT(/usr/local)
+
+ dnl Figure out how to invoke "install" and what install options to use.
+ AC_PROG_INSTALL
diff --git a/russian/nagios/files/patch-ag b/russian/nagios/files/patch-ag
new file mode 100644
index 000000000000..14027c5d9cc9
--- /dev/null
+++ b/russian/nagios/files/patch-ag
@@ -0,0 +1,31 @@
+--- functions Fri Apr 7 11:11:34 2000
++++ functions.new Sat Jun 10 13:31:31 2000
+@@ -11,7 +11,7 @@
+ #
+
+ # First set up a default search path.
+-PATH=/opt/gnu/bin:/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin
++PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/bin:/usr/local/sbin
+ export PATH
+
+ # Get a sane screen width
+@@ -174,7 +174,7 @@
+ # fi
+
+ # Finally try to extract it from ps
+- pid=`ps -eo pid,ppid,fname | egrep -v $$ | awk 'BEGIN { prog=ARGV[1]; ARGC=1 } { if ((prog == $3) || (("(" prog ")") == $3) || (("[" prog "]") == $3) || ((prog ":") == $3)) { print $1 ; exit 0 } }' $1`
++ pid=`ps -axco pid,ppid,command | egrep -v $$ | awk 'BEGIN { prog=ARGV[1]; ARGC=1 } { if ((prog == $3) || (("(" prog ")") == $3) || (("[" prog "]") == $3) || ((prog ":") == $3)) { print $1 ; exit 0 } }' $1`
+ if [ "$pid" != "" ] ; then
+ echo $pid
+ return 0
+@@ -206,8 +206,8 @@
+ fi
+ fi
+
+- # See if /var/lock/subsys/$1 exists
+- if [ -f /var/lock/subsys/$1 ]; then
++ # See if /var/spool/lock/$1 exists
++ if [ -f /var/spool/lock/$1 ]; then
+ echo "$1 dead but subsys locked"
+ return 2
+ fi
diff --git a/russian/nagios/files/patch-ai b/russian/nagios/files/patch-ai
new file mode 100644
index 000000000000..433d6d74758d
--- /dev/null
+++ b/russian/nagios/files/patch-ai
@@ -0,0 +1,25 @@
+--- daemon-init.in.orig Thu Apr 18 06:27:13 2002
++++ daemon-init.in Sun May 19 08:39:29 2002
+@@ -68,11 +68,8 @@
+
+
+ # Source function library
+-# Solaris doesn't have an rc.d directory, so do a test first
+-if [ -f /etc/rc.d/init.d/functions ]; then
+- . /etc/rc.d/init.d/functions
+-elif [ -f /etc/init.d/functions ]; then
+- . /etc/init.d/functions
++if [ -f @sysconfdir@/functions ]; then
++. @sysconfdir@/functions
+ fi
+
+ prefix=@prefix@
+@@ -102,7 +99,7 @@
+
+ start)
+ echo "Starting network monitor: nagios"
+- su -l $Nagios -c "touch $NagiosVar/nagios.log $NagiosSav"
++ su -m $Nagios -c "touch $NagiosVar/nagios.log $NagiosSav"
+ rm -f $NagiosCmd
+ $NagiosBin -d $NagiosCfg
+ if [ -d $NagiosLckDir ]; then touch $NagiosLckDir/$NagiosLckFile; fi
diff --git a/russian/nagios/files/patch-xcddb.c b/russian/nagios/files/patch-xcddb.c
new file mode 100644
index 000000000000..34bc8dc1759a
--- /dev/null
+++ b/russian/nagios/files/patch-xcddb.c
@@ -0,0 +1,11 @@
+--- xdata/xcddb.c.orig Thu May 16 04:46:11 2002
++++ xdata/xcddb.c Thu Mar 6 23:14:25 2003
+@@ -51,7 +51,7 @@
+ #endif
+
+ #ifdef USE_XCDPGSQL
+-#include <pgsql/libpq-fe.h>
++#include <libpq-fe.h>
+ #endif
+
+
diff --git a/russian/nagios/pkg-descr b/russian/nagios/pkg-descr
new file mode 100644
index 000000000000..e4da8a078204
--- /dev/null
+++ b/russian/nagios/pkg-descr
@@ -0,0 +1,3 @@
+nagios v 1.1 with Russian language patches
+
+WWW: http://onix.opennet.ru/
diff --git a/russian/nagios/pkg-install b/russian/nagios/pkg-install
new file mode 100644
index 000000000000..dbc6461bb05e
--- /dev/null
+++ b/russian/nagios/pkg-install
@@ -0,0 +1,68 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PKG_PREFIX=${PKG_PREFIX:=/usr/local}
+
+user=nagios
+group=nagios
+
+ask() {
+ local question default answer
+
+ question=$1
+ default=$2
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ read -p "${question} [${default}]? " answer
+ fi
+ if [ x${answer} = x ]; then
+ answer=${default}
+ fi
+ echo ${answer}
+}
+
+yesno() {
+ local dflt question answer
+
+ question=$1
+ dflt=$2
+ while :; do
+ answer=$(ask "${question}" "${dflt}")
+ case "${answer}" in
+ [Yy]*) return 0;;
+ [Nn]*) return 1;;
+ esac
+ echo "Please answer yes or no."
+ done
+}
+
+if [ x"$2" = xPRE-INSTALL ]; then
+ if /usr/sbin/pw groupshow "${group}" 2>/dev/null; then
+ echo "You already have a group \"${group}\", so I will use it."
+ else
+ echo "You need a group \"${group}\"."
+ if yesno "Would you like me to create it" y; then
+ /usr/sbin/pw groupadd ${group} -h - || exit
+ echo "Done."
+ else
+ echo "Please create it, and try again."
+ exit 1
+ fi
+ fi
+
+ if /usr/sbin/pw user show "${user}" 2>/dev/null; then
+ echo "You already have a user \"${user}\", so I will use it."
+ else
+ echo "You need a user \"${user}\"."
+ if yesno "Would you like me to create it" y; then
+ /usr/sbin/pw useradd ${user} -g ${group} -h - -d ${PKG_PREFIX}/var/nagios \
+ -s /nonexistent -c "Nagios pseudo-user" || exit
+ echo "Done."
+ else
+ echo "Please create it, and try again."
+ exit 1
+ fi
+ fi
+
+fi
diff --git a/russian/nagios/pkg-plist b/russian/nagios/pkg-plist
new file mode 100644
index 000000000000..96865c1dcdce
--- /dev/null
+++ b/russian/nagios/pkg-plist
@@ -0,0 +1,314 @@
+@exec mkdir -p %D/%%DATADIR%%//ssi
+@exec mkdir -p /var/spool/nagios/archives
+@exec mkdir -p /var/spool/nagios/rw
+@exec chmod 775 /var/spool/nagios /var/spool/nagios/archives /var/spool/nagios/rw
+@exec chown nagios:nagios /var/spool/nagios /var/spool/nagios/archives
+@exec chown nagios:nogroup /var/spool/nagios/rw
+bin/nagios
+etc/nagios/cgi.cfg-sample
+etc/nagios/checkcommands.cfg-sample
+etc/nagios/contactgroups.cfg-sample
+etc/nagios/contacts.cfg-sample
+etc/nagios/dependencies.cfg-sample
+etc/nagios/escalations.cfg-sample
+etc/nagios/hostextinfo.cfg-sample
+etc/nagios/hostgroups.cfg-sample
+etc/nagios/hosts.cfg-sample
+etc/nagios/misccommands.cfg-sample
+etc/nagios/nagios.cfg-sample
+etc/nagios/resource.cfg-sample
+etc/nagios/serviceextinfo.cfg-sample
+etc/nagios/services.cfg-sample
+etc/nagios/timeperiods.cfg-sample
+etc/rc.d/nagios.sh
+%%DATADIR%%/cgi-bin/avail.cgi
+%%DATADIR%%/cgi-bin/cmd.cgi
+%%DATADIR%%/cgi-bin/config.cgi
+%%DATADIR%%/cgi-bin/extinfo.cgi
+%%DATADIR%%/cgi-bin/histogram.cgi
+%%DATADIR%%/cgi-bin/history.cgi
+%%DATADIR%%/cgi-bin/notifications.cgi
+%%DATADIR%%/cgi-bin/outages.cgi
+%%DATADIR%%/cgi-bin/showlog.cgi
+%%DATADIR%%/cgi-bin/status.cgi
+%%DATADIR%%/cgi-bin/statusmap.cgi
+%%DATADIR%%/cgi-bin/statuswml.cgi
+%%DATADIR%%/cgi-bin/statuswrl.cgi
+%%DATADIR%%/cgi-bin/summary.cgi
+%%DATADIR%%/cgi-bin/tac.cgi
+%%DATADIR%%/cgi-bin/trends.cgi
+%%DATADIR%%/contexthelp/A1.html
+%%DATADIR%%/contexthelp/A2.html
+%%DATADIR%%/contexthelp/A3.html
+%%DATADIR%%/contexthelp/A4.html
+%%DATADIR%%/contexthelp/A5.html
+%%DATADIR%%/contexthelp/A6.html
+%%DATADIR%%/contexthelp/A7.html
+%%DATADIR%%/contexthelp/B1.html
+%%DATADIR%%/contexthelp/C1.html
+%%DATADIR%%/contexthelp/D1.html
+%%DATADIR%%/contexthelp/E1.html
+%%DATADIR%%/contexthelp/F1.html
+%%DATADIR%%/contexthelp/G1.html
+%%DATADIR%%/contexthelp/G2.html
+%%DATADIR%%/contexthelp/G3.html
+%%DATADIR%%/contexthelp/G4.html
+%%DATADIR%%/contexthelp/G5.html
+%%DATADIR%%/contexthelp/G6.html
+%%DATADIR%%/contexthelp/H1.html
+%%DATADIR%%/contexthelp/H2.html
+%%DATADIR%%/contexthelp/H3.html
+%%DATADIR%%/contexthelp/H4.html
+%%DATADIR%%/contexthelp/H5.html
+%%DATADIR%%/contexthelp/H6.html
+%%DATADIR%%/contexthelp/H7.html
+%%DATADIR%%/contexthelp/H8.html
+%%DATADIR%%/contexthelp/I1.html
+%%DATADIR%%/contexthelp/I2.html
+%%DATADIR%%/contexthelp/I3.html
+%%DATADIR%%/contexthelp/I4.html
+%%DATADIR%%/contexthelp/I5.html
+%%DATADIR%%/contexthelp/I6.html
+%%DATADIR%%/contexthelp/I7.html
+%%DATADIR%%/contexthelp/I8.html
+%%DATADIR%%/contexthelp/J1.html
+%%DATADIR%%/contexthelp/K1.html
+%%DATADIR%%/contexthelp/L1.html
+%%DATADIR%%/contexthelp/L10.html
+%%DATADIR%%/contexthelp/L11.html
+%%DATADIR%%/contexthelp/L12.html
+%%DATADIR%%/contexthelp/L13.html
+%%DATADIR%%/contexthelp/L2.html
+%%DATADIR%%/contexthelp/L3.html
+%%DATADIR%%/contexthelp/L4.html
+%%DATADIR%%/contexthelp/L5.html
+%%DATADIR%%/contexthelp/L6.html
+%%DATADIR%%/contexthelp/L7.html
+%%DATADIR%%/contexthelp/L8.html
+%%DATADIR%%/contexthelp/L9.html
+%%DATADIR%%/contexthelp/M1.html
+%%DATADIR%%/contexthelp/M2.html
+%%DATADIR%%/contexthelp/M3.html
+%%DATADIR%%/contexthelp/M4.html
+%%DATADIR%%/contexthelp/M5.html
+%%DATADIR%%/contexthelp/M6.html
+%%DATADIR%%/contexthelp/N1.html
+%%DATADIR%%/contexthelp/N2.html
+%%DATADIR%%/contexthelp/N3.html
+%%DATADIR%%/contexthelp/N4.html
+%%DATADIR%%/contexthelp/N5.html
+%%DATADIR%%/contexthelp/N6.html
+%%DATADIR%%/contexthelp/N7.html
+%%DATADIR%%/docs/images/activepassive.png
+%%DATADIR%%/docs/images/cgi-avail-a.png
+%%DATADIR%%/docs/images/cgi-avail-b.png
+%%DATADIR%%/docs/images/cgi-cmd.png
+%%DATADIR%%/docs/images/cgi-config.png
+%%DATADIR%%/docs/images/cgi-extinfo-a.png
+%%DATADIR%%/docs/images/cgi-extinfo-b.png
+%%DATADIR%%/docs/images/cgi-extinfo-c.png
+%%DATADIR%%/docs/images/cgi-extinfo-d.png
+%%DATADIR%%/docs/images/cgi-histogram.png
+%%DATADIR%%/docs/images/cgi-history.png
+%%DATADIR%%/docs/images/cgi-notifications.png
+%%DATADIR%%/docs/images/cgi-outages.png
+%%DATADIR%%/docs/images/cgi-showlog.png
+%%DATADIR%%/docs/images/cgi-status-a.png
+%%DATADIR%%/docs/images/cgi-status-b.png
+%%DATADIR%%/docs/images/cgi-status-c.png
+%%DATADIR%%/docs/images/cgi-status-d.png
+%%DATADIR%%/docs/images/cgi-statusmap.png
+%%DATADIR%%/docs/images/cgi-statuswml.png
+%%DATADIR%%/docs/images/cgi-statuswrl.png
+%%DATADIR%%/docs/images/cgi-summary.png
+%%DATADIR%%/docs/images/cgi-tac.png
+%%DATADIR%%/docs/images/cgi-trends.png
+%%DATADIR%%/docs/images/checktiming.png
+%%DATADIR%%/docs/images/distributed.png
+%%DATADIR%%/docs/images/host-dependencies.png
+%%DATADIR%%/docs/images/indirecthostcheck.png
+%%DATADIR%%/docs/images/indirectsvccheck.png
+%%DATADIR%%/docs/images/indirectsvccheck2.png
+%%DATADIR%%/docs/images/interleaved1.png
+%%DATADIR%%/docs/images/interleaved2.png
+%%DATADIR%%/docs/images/interleaved3.png
+%%DATADIR%%/docs/images/logofullsize.png
+%%DATADIR%%/docs/images/network-heirarchy.png
+%%DATADIR%%/docs/images/network-outage1.png
+%%DATADIR%%/docs/images/network-outage2.png
+%%DATADIR%%/docs/images/noninterleaved1.png
+%%DATADIR%%/docs/images/noninterleaved2.png
+%%DATADIR%%/docs/images/physical-network.png
+%%DATADIR%%/docs/images/plugintheory.png
+%%DATADIR%%/docs/images/redudancy.png
+%%DATADIR%%/docs/images/redundancy.png
+%%DATADIR%%/docs/images/service-dependencies.png
+%%DATADIR%%/docs/images/statetransitions.png
+%%DATADIR%%/docs/images/statetransitions2.png
+%%DATADIR%%/docs/about.html
+%%DATADIR%%/docs/addons.html
+%%DATADIR%%/docs/beginners.html
+%%DATADIR%%/docs/cgiauth.html
+%%DATADIR%%/docs/cgiincludes.html
+%%DATADIR%%/docs/cgis.html
+%%DATADIR%%/docs/checkscheduling.html
+%%DATADIR%%/docs/clusters.html
+%%DATADIR%%/docs/commandfile.html
+%%DATADIR%%/docs/config.html
+%%DATADIR%%/docs/configcgi.html
+%%DATADIR%%/docs/configextinfo.html
+%%DATADIR%%/docs/configmain.html
+%%DATADIR%%/docs/configobject.html
+%%DATADIR%%/docs/dependencies.html
+%%DATADIR%%/docs/distributed.html
+%%DATADIR%%/docs/downtime.html
+%%DATADIR%%/docs/embeddedperl.html
+%%DATADIR%%/docs/escalations.html
+%%DATADIR%%/docs/eventhandlers.html
+%%DATADIR%%/docs/extcommands.html
+%%DATADIR%%/docs/faqs.html
+%%DATADIR%%/docs/flapping.html
+%%DATADIR%%/docs/freshness.html
+%%DATADIR%%/docs/funstuff.html
+%%DATADIR%%/docs/index.html
+%%DATADIR%%/docs/indirectchecks.html
+%%DATADIR%%/docs/installing.html
+%%DATADIR%%/docs/installweb.html
+%%DATADIR%%/docs/int-portsentry.html
+%%DATADIR%%/docs/int-snmptrap.html
+%%DATADIR%%/docs/int-tcpwrappers.html
+%%DATADIR%%/docs/macros.html
+%%DATADIR%%/docs/networkoutages.html
+%%DATADIR%%/docs/networkreachability.html
+%%DATADIR%%/docs/notifications.html
+%%DATADIR%%/docs/parallelization.html
+%%DATADIR%%/docs/passivechecks.html
+%%DATADIR%%/docs/perfdata.html
+%%DATADIR%%/docs/plugins.html
+%%DATADIR%%/docs/plugintheory.html
+%%DATADIR%%/docs/redundancy.html
+%%DATADIR%%/docs/robots.txt
+%%DATADIR%%/docs/security.html
+%%DATADIR%%/docs/stalking.html
+%%DATADIR%%/docs/starting.html
+%%DATADIR%%/docs/statetypes.html
+%%DATADIR%%/docs/stoprestart.html
+%%DATADIR%%/docs/templaterecursion.html
+%%DATADIR%%/docs/templatetricks.html
+%%DATADIR%%/docs/timeperiods.html
+%%DATADIR%%/docs/toc.html
+%%DATADIR%%/docs/tuning.html
+%%DATADIR%%/docs/verifyconfig.html
+%%DATADIR%%/docs/volatileservices.html
+%%DATADIR%%/docs/whatsnew.html
+%%DATADIR%%/docs/xdata-db.html
+%%DATADIR%%/docs/xeddefault.html
+%%DATADIR%%/docs/xedtemplate.html
+%%DATADIR%%/docs/xoddefault.html
+%%DATADIR%%/docs/xodtemplate.html
+%%DATADIR%%/docs/xpddefault.html
+%%DATADIR%%/docs/xpdfile.html
+%%DATADIR%%/images/ack.gif
+%%DATADIR%%/images/command.png
+%%DATADIR%%/images/comment.gif
+%%DATADIR%%/images/contexthelp1.gif
+%%DATADIR%%/images/contexthelp2.gif
+%%DATADIR%%/images/critical.png
+%%DATADIR%%/images/delay.gif
+%%DATADIR%%/images/delete.gif
+%%DATADIR%%/images/disabled.gif
+%%DATADIR%%/images/down.gif
+%%DATADIR%%/images/downtime.gif
+%%DATADIR%%/images/empty.gif
+%%DATADIR%%/images/enabled.gif
+%%DATADIR%%/images/extinfo.gif
+%%DATADIR%%/images/flapping.gif
+%%DATADIR%%/images/greendot.gif
+%%DATADIR%%/images/histogram.png
+%%DATADIR%%/images/history.gif
+%%DATADIR%%/images/hostevent.gif
+%%DATADIR%%/images/info.png
+%%DATADIR%%/images/left.gif
+%%DATADIR%%/images/logofullsize.jpg
+%%DATADIR%%/images/logos/nagios.gd2
+%%DATADIR%%/images/logos/nagios.gif
+%%DATADIR%%/images/logos/nagiosvrml.png
+%%DATADIR%%/images/logos/unknown.gd2
+%%DATADIR%%/images/logos/unknown.gif
+%%DATADIR%%/images/logrotate.png
+%%DATADIR%%/images/ndisabled.gif
+%%DATADIR%%/images/noack.gif
+%%DATADIR%%/images/notes.gif
+%%DATADIR%%/images/notify.gif
+%%DATADIR%%/images/orangedot.gif
+%%DATADIR%%/images/passiveonly.gif
+%%DATADIR%%/images/recovery.png
+%%DATADIR%%/images/redudancy.png
+%%DATADIR%%/images/redundancy.png
+%%DATADIR%%/images/restart.gif
+%%DATADIR%%/images/right.gif
+%%DATADIR%%/images/sbconfig.png
+%%DATADIR%%/images/sbgeneral.png
+%%DATADIR%%/images/sblogo.jpg
+%%DATADIR%%/images/sbmonitor.png
+%%DATADIR%%/images/sbreport.png
+%%DATADIR%%/images/serviceevent.gif
+%%DATADIR%%/images/start.gif
+%%DATADIR%%/images/status.gif
+%%DATADIR%%/images/status2.gif
+%%DATADIR%%/images/status3.gif
+%%DATADIR%%/images/status4.gif
+%%DATADIR%%/images/stop.gif
+%%DATADIR%%/images/tacdisabled.jpg
+%%DATADIR%%/images/tacdisabled.png
+%%DATADIR%%/images/tacenabled.jpg
+%%DATADIR%%/images/tacenabled.png
+%%DATADIR%%/images/thermcrit.png
+%%DATADIR%%/images/thermok.png
+%%DATADIR%%/images/thermwarn.png
+%%DATADIR%%/images/trends.gif
+%%DATADIR%%/images/trendshost.png
+%%DATADIR%%/images/trendssvc.png
+%%DATADIR%%/images/unknown.png
+%%DATADIR%%/images/up.gif
+%%DATADIR%%/images/warning.png
+%%DATADIR%%/images/weblogo1.png
+%%DATADIR%%/images/zoom1.gif
+%%DATADIR%%/images/zoom2.gif
+%%DATADIR%%/index.html
+%%DATADIR%%/main.html
+%%DATADIR%%/media/critical.wav
+%%DATADIR%%/media/hostdown.wav
+%%DATADIR%%/media/warning.wav
+%%DATADIR%%/robots.txt
+%%DATADIR%%/side.html
+%%DATADIR%%/stylesheets/avail.css
+%%DATADIR%%/stylesheets/checksanity.css
+%%DATADIR%%/stylesheets/cmd.css
+%%DATADIR%%/stylesheets/config.css
+%%DATADIR%%/stylesheets/extinfo.css
+%%DATADIR%%/stylesheets/histogram.css
+%%DATADIR%%/stylesheets/history.css
+%%DATADIR%%/stylesheets/ministatus.css
+%%DATADIR%%/stylesheets/notifications.css
+%%DATADIR%%/stylesheets/outages.css
+%%DATADIR%%/stylesheets/showlog.css
+%%DATADIR%%/stylesheets/status.css
+%%DATADIR%%/stylesheets/statusmap.css
+%%DATADIR%%/stylesheets/summary.css
+%%DATADIR%%/stylesheets/tac.css
+%%DATADIR%%/stylesheets/trends.css
+@unexec rmdir %D/etc/nagios 2>/dev/null || true
+@dirrm %%DATADIR%%/cgi-bin
+@dirrm %%DATADIR%%/contexthelp
+@dirrm %%DATADIR%%/docs/images
+@dirrm %%DATADIR%%/docs
+@dirrm %%DATADIR%%/images/logos
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%/media
+@dirrm %%DATADIR%%/ssi
+@dirrm %%DATADIR%%/stylesheets
+@dirrm %%DATADIR%%/
+@unexec rmdir /var/spool/nagios/archives 2>/dev/null || true
+@unexec rmdir /var/spool/nagios/rw 2>/dev/null || true
+@unexec rmdir /var/spool/nagios 2>/dev/null || true