aboutsummaryrefslogtreecommitdiff
path: root/science/chemtool/files
diff options
context:
space:
mode:
Diffstat (limited to 'science/chemtool/files')
-rw-r--r--science/chemtool/files/patch-Makefile.in14
-rw-r--r--science/chemtool/files/patch-src-cht_Makefile.in14
-rw-r--r--science/chemtool/files/patch-src-cht_cht-2.1.c32
-rw-r--r--science/chemtool/files/patch-undo.c14
4 files changed, 7 insertions, 67 deletions
diff --git a/science/chemtool/files/patch-Makefile.in b/science/chemtool/files/patch-Makefile.in
index 7125b80875e9..527f9f473520 100644
--- a/science/chemtool/files/patch-Makefile.in
+++ b/science/chemtool/files/patch-Makefile.in
@@ -1,8 +1,8 @@
$FreeBSD$
---- Makefile.in.orig Thu Apr 11 21:41:37 2002
-+++ Makefile.in Fri Aug 30 01:25:01 2002
+--- Makefile.in.orig Sun May 11 22:02:15 2003
++++ Makefile.in Sun Jul 20 22:49:21 2003
@@ -5,7 +5,7 @@
mandir=@mandir@
kdedir=@kdemimedir@
@@ -13,11 +13,11 @@ $FreeBSD$
CC=@CC@
CP=/bin/cp
@@ -16,7 +16,7 @@
- SRCS = main.c chemproc.c graph.c draw.c inout.c gtkfilesel.c undo.c
- OBJS = main.o chemproc.o graph.o draw.o inout.o gtkfilesel.o undo.o
+ SRCS = main.c chemproc.c graph.c draw.c inout.c undo.c @MYGTKSRCS@
+ OBJS = main.o chemproc.o graph.o draw.o inout.o undo.o @MYGTKOBJS@
--SYS_LIBRARIES = `gtk-config --libs` -lm
-+SYS_LIBRARIES = `${GTK_CONFIG} --libs` -lm
+-SYS_LIBRARIES = `gtk-config --libs` @EMFLIBS@ -lm
++SYS_LIBRARIES = `${GTK_CONFIG} --libs` @EMFLIBS@ -lm
+
all: chemtool cht
-
diff --git a/science/chemtool/files/patch-src-cht_Makefile.in b/science/chemtool/files/patch-src-cht_Makefile.in
deleted file mode 100644
index 3760a2002085..000000000000
--- a/science/chemtool/files/patch-src-cht_Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src-cht/Makefile.in.orig Fri Aug 30 01:23:49 2002
-+++ src-cht/Makefile.in Fri Aug 30 01:24:27 2002
-@@ -1,4 +1,7 @@
-+CC=@CC@
-+CFLAGS=@CFLAGS@
-+
- default: cht
-
- cht: cht-2.1.c
-- gcc -O cht-2.1.c -o cht
-+ $(CC) $(CFLAGS) -o cht cht-2.1.c
diff --git a/science/chemtool/files/patch-src-cht_cht-2.1.c b/science/chemtool/files/patch-src-cht_cht-2.1.c
deleted file mode 100644
index e8b486678f73..000000000000
--- a/science/chemtool/files/patch-src-cht_cht-2.1.c
+++ /dev/null
@@ -1,32 +0,0 @@
-
-$FreeBSD$
-
---- src-cht/cht-2.1.c.orig Fri Aug 30 01:25:46 2002
-+++ src-cht/cht-2.1.c Fri Aug 30 01:31:51 2002
-@@ -1431,7 +1431,7 @@
- {
- #ifndef NO_TIME
- struct tm *tm;
-- long clock;
-+ time_t clock;
-
- time(&clock);
- tm = localtime(&clock);
-@@ -1449,7 +1449,7 @@
- Void VAXdate(s)
- char *s;
- {
-- long clock;
-+ time_t clock;
- char *c;
- int i;
- static int where[] = {8, 9, 0, 4, 5, 6, 0, 20, 21, 22, 23};
-@@ -1465,7 +1465,7 @@
- Void VAXtime(s)
- char *s;
- {
-- long clock;
-+ time_t clock;
- char *c;
- int i;
-
diff --git a/science/chemtool/files/patch-undo.c b/science/chemtool/files/patch-undo.c
deleted file mode 100644
index ff8442f1c072..000000000000
--- a/science/chemtool/files/patch-undo.c
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- undo.c.orig Sat Mar 9 17:27:32 2002
-+++ undo.c Fri Aug 30 00:12:23 2002
-@@ -61,7 +61,7 @@
- #define MAP_NEW_ANON_AT_FLAGS(pos, size, flags) \
- (mmap((pos), (size), \
- PROT_READ | PROT_WRITE | PROT_EXEC, \
-- MAP_PRIVATE | MAP_ANONYMOUS | (flags), 0, 0))
-+ MAP_PRIVATE | MAP_ANON | (flags), -1, 0))
- #define MAP_NEW_ANON(size) MAP_NEW_ANON_AT_FLAGS(0, (size), 0)
- #define MAP_NEW_ANON_AT(pos, size) \
- MAP_NEW_ANON_AT_FLAGS((pos), (size), MAP_FIXED)