aboutsummaryrefslogtreecommitdiff
path: root/science/felt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/felt/Makefile')
-rw-r--r--science/felt/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/science/felt/Makefile b/science/felt/Makefile
index 6cdeb048382c..36e372b57745 100644
--- a/science/felt/Makefile
+++ b/science/felt/Makefile
@@ -29,6 +29,12 @@ MAN1= burlap.1 corduroy.1 felt.1 patchwork.1 velvet.1 yardstick.1
MAN3= Drawing.3
MAN4= corduroy.4 felt.4
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>, ; s,"malloc.h",<stdlib.h>,' \
${WRKSRC}/lib/Felt/parser.c \
@@ -47,4 +53,4 @@ post-install:
${MKDIR} ${PREFIX}/share/doc/FElt
${CP} ${WRKSRC}/*.html ${PREFIX}/share/doc/FElt
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>