aboutsummaryrefslogtreecommitdiff
path: root/science/fvcom-mpi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/fvcom-mpi/Makefile')
-rw-r--r--science/fvcom-mpi/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/science/fvcom-mpi/Makefile b/science/fvcom-mpi/Makefile
new file mode 100644
index 000000000000..15a711d3596f
--- /dev/null
+++ b/science/fvcom-mpi/Makefile
@@ -0,0 +1,15 @@
+# Created by: Jason Bacon <jwbacon@tds.net>
+# $FreeBSD$
+
+PKGNAMESUFFIX= -mpi
+
+MAINTAINER= jwbacon@tds.net
+
+LIB_DEPENDS+= mpi:${PORTSDIR}/net/openmpi
+
+MASTERDIR= ${.CURDIR}/../fvcom
+
+MAKE_ARGS+= FC=${LOCALBASE}/mpi/openmpi/bin/mpif90 \
+ PORT_CPP_FLAGS+=-DMULTIPROCESSOR
+
+.include "${MASTERDIR}/Makefile"