aboutsummaryrefslogtreecommitdiff
path: root/science/gabedit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/gabedit/Makefile')
-rw-r--r--science/gabedit/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/science/gabedit/Makefile b/science/gabedit/Makefile
index ac2ccb3a155f..7d4b86d1be9d 100644
--- a/science/gabedit/Makefile
+++ b/science/gabedit/Makefile
@@ -1,13 +1,10 @@
# $FreeBSD$
PORTNAME= gabedit
-DISTVERSION= 2.5.1
-PORTREVISION= 4
+DISTVERSION= 2.5.1-300720 # the last number is "snapshot"
CATEGORIES= science
-#MASTER_SITES= http://prdownloads.sourceforge.net/${PORTNAME}/ # old SF-based source
-#DISTNAME= GabeditSrc${DISTVERSION:S/.//g}
-MASTER_SITES= https://sites.google.com/site/allouchear/Home/gabedit/download/ # development version now on sites.google.com, browse to the same URL for details
-DISTNAME= GabeditSrc${DISTVERSION:S/.//g}_061218
+MASTER_SITES= https://sites.google.com/site/allouchear/Home/gabedit/download/
+DISTNAME= GabeditSrc${DISTVERSION:C/([0-9])\.([0-9])\.([0-9])-([0-9])/\1\2\3_\4/}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Graphical user interface for several chemistry software packages
@@ -28,6 +25,8 @@ USE_GL= gl glu
USE_XORG= ice sm x11 xmu xt
INSTALLS_ICONS= yes
+CFLAGS+= -fcommon # change the default because GlobalOrb.h has many common definitions
+
BINARY_ALIAS= make=gmake
PLIST_FILES= bin/${PORTNAME} \