aboutsummaryrefslogtreecommitdiff
path: root/science/gamess
diff options
context:
space:
mode:
Diffstat (limited to 'science/gamess')
-rw-r--r--science/gamess/Makefile3
-rw-r--r--science/gamess/files/patch-rungms17
-rw-r--r--science/gamess/pkg-plist10
3 files changed, 21 insertions, 9 deletions
diff --git a/science/gamess/Makefile b/science/gamess/Makefile
index 47deabc6791b..e050a7a688cb 100644
--- a/science/gamess/Makefile
+++ b/science/gamess/Makefile
@@ -116,6 +116,7 @@ do-build:
do-install:
${MKDIR} ${PREFIX}/bin/gms
${MKDIR} ${PREFIX}/share/gamess
+ ${MKDIR} ${PREFIX}/share/gamess/mcpdata
${MKDIR} ${PREFIX}/share/doc/gamess
${MKDIR} ${PREFIX}/share/examples/gamess
${INSTALL_SCRIPT} ${WRKDIR}/gamess/rungms ${PREFIX}/bin/gamess
@@ -125,5 +126,7 @@ do-install:
${INSTALL_DATA} ${WRKDIR}/gamess/*.DOC ${PREFIX}/share/doc/gamess/
${INSTALL_DATA} ${WRKDIR}/gamess/tests/*.inp ${PREFIX}/share/examples/gamess/
${INSTALL_DATA} ${WRKDIR}/gamess/ericfmt.dat ${PREFIX}/share/gamess/
+ ${INSTALL_DATA} ${WRKDIR}/gamess/mcpdata/* ${PREFIX}/share/gamess/mcpdata/
+ ${INSTALL_DATA} ${WRKDIR}/gamess/ddi/readme.ddi ${PREFIX}/share/doc/gamess/
.include <bsd.port.post.mk>
diff --git a/science/gamess/files/patch-rungms b/science/gamess/files/patch-rungms
index 0a6d823ad7ac..6467b62d3262 100644
--- a/science/gamess/files/patch-rungms
+++ b/science/gamess/files/patch-rungms
@@ -1,5 +1,5 @@
---- rungms.orig Thu Jun 7 07:03:07 2007
-+++ rungms Thu Aug 2 11:17:25 2007
+--- rungms.orig Wed Jun 6 17:03:07 2007
++++ rungms Wed Sep 26 14:31:55 2007
@@ -1,4 +1,4 @@
-#!/bin/csh
+#!/bin/csh -f
@@ -21,7 +21,7 @@
#
set JOB=$1 # name of the input file xxx.inp, give only the xxx part
set VERNO=$2 # revision number of the executable created by 'lked' step
-@@ -66,35 +73,45 @@
+@@ -66,35 +72,45 @@
#
# ---- the top third of the script is input and other file assignments ----
#
@@ -38,8 +38,9 @@
+#df -k $SCR
# this added as experiment, February 2007
- limit stacksize 8192
-
+-limit stacksize 8192
++#limit stacksize 8192
++
+set JOBORG=$JOB
+set JOB=$JOB:r # strip off possible .inp
+
@@ -49,7 +50,7 @@
+ echo "Input file $JOBORG does not exist. Please fix and resubmit."
+ exit 4
+endif
-+
+
# Grab a copy of the input file.
# In the case of EXAMnn jobs, this file might be in the "tests" subdirectory.
-if ($JOB:r.inp == $JOB) set JOB=$JOB:r # strip off possible .inp
@@ -89,7 +90,7 @@
# file assignments.
#
-@@ -117,16 +134,16 @@
+@@ -117,16 +133,16 @@
# d. see NEO plug-in code's documentation regarding the NUCBAS file.
# Note that you must edit a+b, but will probably skip c+d.
#
@@ -111,7 +112,7 @@
setenv AOINTS $SCR/$JOB.F08
setenv MOINTS $SCR/$JOB.F09
setenv DICTNRY $SCR/$JOB.F10
-@@ -156,8 +173,8 @@
+@@ -156,8 +172,8 @@
setenv SOINTY $SCR/$JOB.F32
setenv SOINTZ $SCR/$JOB.F33
setenv SORESC $SCR/$JOB.F34
diff --git a/science/gamess/pkg-plist b/science/gamess/pkg-plist
index 4bfa42f08aca..bcc5e7557794 100644
--- a/science/gamess/pkg-plist
+++ b/science/gamess/pkg-plist
@@ -7,7 +7,15 @@ share/doc/gamess/IRON.DOC
share/doc/gamess/PROG.DOC
share/doc/gamess/REFS.DOC
share/doc/gamess/TESTS.DOC
+share/doc/gamess/readme.ddi
share/gamess/ericfmt.dat
+share/gamess/mcpdata/IMCP-NR1
+share/gamess/mcpdata/IMCP-NR2
+share/gamess/mcpdata/IMCP-SR1
+share/gamess/mcpdata/IMCP-SR2
+share/gamess/mcpdata/MCP-DZP
+share/gamess/mcpdata/MCP-QZP
+share/gamess/mcpdata/MCP-TZP
share/examples/gamess/exam01.inp
share/examples/gamess/exam02.inp
share/examples/gamess/exam03.inp
@@ -52,6 +60,6 @@ share/examples/gamess/exam41.inp
share/examples/gamess/exam42.inp
@dirrm bin/gms
@dirrm share/doc/gamess
+@dirrm share/gamess/mcpdata
@dirrm share/gamess
@dirrm share/examples/gamess
-