aboutsummaryrefslogtreecommitdiff
path: root/science/gave/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/gave/Makefile')
-rw-r--r--science/gave/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/science/gave/Makefile b/science/gave/Makefile
index 2a5a98e7e641..37daa54f225d 100644
--- a/science/gave/Makefile
+++ b/science/gave/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gave
-PORTVERSION= 1.0.3
-PORTREVISION= 1
+PORTVERSION= 1.1.3
CATEGORIES= science graphics ruby
MASTER_SITES= http://ruby.gfd-dennou.org/products/gave/
DIST_SUBDIR= ruby
@@ -16,7 +15,7 @@ MAINTAINER= murakami@ahs.scitec.kobe-u.ac.jp
COMMENT= A gtk+ based grid data analyser and viewer written in Ruby
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray \
- ${RUBY_SITEARCHLIBDIR}/numru/dcl_raw.so:${PORTSDIR}/science/ruby-dcl-gtk \
+ ${RUBY_SITEARCHLIBDIR}/numru/dcl_raw.so:${PORTSDIR}/science/ruby-dcl \
${RUBY_SITEARCHLIBDIR}/numru/netcdfraw.so:${PORTSDIR}/math/ruby-netcdf \
${RUBY_SITELIBDIR}/numru/gphys.rb:${PORTSDIR}/science/ruby-gphys \
${RUBY_SITEARCHLIBDIR}/libglade2.so:${PORTSDIR}/devel/ruby-libglade2 \
@@ -24,8 +23,7 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray \
${RUBY_SITEARCHLIBDIR}/gnomevfs.so:${PORTSDIR}/devel/ruby-gnomevfs
USE_RUBY= yes
-NO_BUILD= yes
-USE_REINPLACE= yes
+USE_RUBY_SETUP= yes
.include <bsd.port.pre.mk>
@@ -38,10 +36,14 @@ RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/iconv.so:${PORTSDIR}/converters/ruby-iconv
.endif
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's/sitelibdir\+\"\/numru\/\"\+package/sitelibdir\+\"\/\"\+package/' ${WRKSRC}/install.rb
+DOCS= ChangeLog README
-do-install:
- @cd ${WRKSRC}/ && ${RUBY} ./install.rb --localedir=${PREFIX}/share/locale/
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/gave
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/gave
+.endfor
+.endif
.include <bsd.port.post.mk>