aboutsummaryrefslogtreecommitdiff
path: root/science/hdf5-18/files/hdf
diff options
context:
space:
mode:
Diffstat (limited to 'science/hdf5-18/files/hdf')
-rw-r--r--science/hdf5-18/files/hdf/Makefile9
-rw-r--r--science/hdf5-18/files/hdf/src/Makefile54
-rw-r--r--science/hdf5-18/files/hdf/test/Makefile68
-rw-r--r--science/hdf5-18/files/hdf/util/Makefile30
4 files changed, 0 insertions, 161 deletions
diff --git a/science/hdf5-18/files/hdf/Makefile b/science/hdf5-18/files/hdf/Makefile
deleted file mode 100644
index 1f9663c03246..000000000000
--- a/science/hdf5-18/files/hdf/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-# $FreeBSD$
-
-SUBDIR = src util test
-
-hdf-test: all
- cd util && ${MAKE} test
- cd test && ${MAKE} test
-
-.include <bsd.subdir.mk>
diff --git a/science/hdf5-18/files/hdf/src/Makefile b/science/hdf5-18/files/hdf/src/Makefile
deleted file mode 100644
index 5dde282ec816..000000000000
--- a/science/hdf5-18/files/hdf/src/Makefile
+++ /dev/null
@@ -1,54 +0,0 @@
-# $FreeBSD$
-
-LIB=df
-
-# uncomment the line below to avoid building static libraries
-#INTERNALLIB=YES
-LIBDIR=${PREFIX}/lib
-
-SHLIB_MAJOR=1
-SHLIB_MINOR=0
-
-SRCS=atom.c bitvect.c cdeflate.c cnbit.c cnone.c crle.c cskphuff.c \
- df24.c df24f.c dfan.c dfanf.c dfcomp.c dfconv.c dff.c dfgr.c \
- dfgroup.c dfimcomp.c dfjpeg.c dfkconv.c dfkcray.c dfkfuji.c \
- dfknat.c dfkswap.c dfkvms.c dfp.c dfpf.c dfr8.c dfr8f.c dfrle.c \
- dfsd.c dfsdf.c dfstubs.c dfufp2i.c dfunjpeg.c dfutil.c dfutilf.c \
- dir_mac.c dynarray.c glist.c hbitio.c hblocks.c hbuffer.c \
- hchunks.c hcomp.c hcompri.c hdfalloc.c herr.c herrf.c hextelt.c \
- hfile.c hfiledd.c hfilef.c hkit.c linklist.c mcache.c \
- mfan.c mfanf.c mfgr.c mfgrf.c mstdio.c tbbt.c vattr.c vattrf.c \
- vconv.c vg.c vgf.c vgp.c vhi.c vio.c vparse.c vrw.c vsfld.c \
- df24ff.f dfanff.f dfff.f dfpff.f dfr8ff.f dfsdff.f dfufp2if.f \
- hfileff.f mfgrff.f vattrff.f vgff.f
-
-CFLAGS += -I${PREFIX}/include
-FFLAGS += ${CFLAGS}
-
-.if !defined(OSVERSION)
-.if exists(/sbin/sysctl)
-OSVERSION!= /sbin/sysctl -n kern.osreldate
-.else
-OSVERSION!= /usr/sbin/sysctl -n kern.osreldate
-.endif
-.endif
-
-.if ${OSVERSION} >= 400004
-LDADD += -L${PREFIX}/lib -ljpeg -lg2c -lz -lm
-.else
-LDADD += -L${PREFIX}/lib -ljpeg -lf2c -lz
-.endif
-
-afterinstall:
- install -c -o root -g wheel -m 444 \
- atom.h bitvect.h cdeflate.h cnbit.h cnone.h crle.h \
- cskphuff.h df.h dfan.h dfconvrt.h dfgr.h dfi.h dfivms.h \
- dfrig.h dfsd.h dfstubs.h dfufp2i.h dir_mac.h dynarray.h \
- glist.h hbitio.h hchunks.h hcomp.h hcompi.h hconv.h \
- hdf.h hdfi.h herr.h hfile.h hkit.h hlimits.h hntdefs.h \
- hproto.h hqueue.h htags.h linklist.h maldebug.h mcache.h \
- mfan.h mfgr.h mstdio.h patchlevel.h sys_dir_mac.h tbbt.h \
- trace.h vattr.h vg.h vgint.h hdf.inc dffunc.inc \
- ${PREFIX}/include
-
-.include <bsd.lib.mk>
diff --git a/science/hdf5-18/files/hdf/test/Makefile b/science/hdf5-18/files/hdf/test/Makefile
deleted file mode 100644
index 3a3c8ca98524..000000000000
--- a/science/hdf5-18/files/hdf/test/Makefile
+++ /dev/null
@@ -1,68 +0,0 @@
-# $FreeBSD$
-
-CSRCS= rig.c sdstr.c blocks.c an.c anfile.c extelt.c file.c file1.c vers.c \
- sdmms.c sdnmms.c slab.c litend.c tvset.c comp.c bitio.c tree.c macros.c \
- conv.c nbit.c man.c mgr.c testhdf.c tbv.c tvsfpack.c chunks.c tvattr.c \
- buffer.c
-
-COBJS= ${CSRCS:S/.c/.o/g}
-
-FSRCS= fortest.c fortestF.f forsupff.f forsupf.c \
- manf.f mgrf.f slabwf.f t24f.f tanf.f tanfilef.f tpf.f tr8f.f \
- tsdmmsf.f tsdnmmsf.f tsdnntf.f tsdntf.f tsdstrf.f tstubsf.f \
- tvsetf.f, tvattrf.f
-
-FOBJS = fortestF.o forsupff.o forsupf.o \
- manf.o mgrf.o slabwf.o t24f.o tanf.o tanfilef.o tpf.o tr8f.o \
- tsdmmsf.o tsdnmmsf.o tsdnntf.o tsdntf.o tsdstrf.o tstubsf.o \
- tvsetf.o tvattrf.o
-
-#CFORSUPSRCS = forsupf.c
-
-HDFLIB = ${.CURDIR}/../src
-CFLAGS += -I${HDFLIB}
-FFLAGS += ${CFLAGS} -Nn802 -Nx400
-
-FTESTS = fortest fortestF
-
-all: testhdf $(FTESTS) gentest
-
-#CFORSUPOBJS = forsupf.o
-
-TESTF = fortest.o
-
-# directory used by extelt test.
-TESTDIR = testdir
-
-$(FOBJS): fortest.inc
-
-test: atest-hdf
-
-atest-hdf: testhdf $(FTESTS)
- -rm -f *.hdf
- env LD_LIBRARY_PATH=${.CURDIR}/../src ./testhdf
- -rm -f *.hdf
- env LD_LIBRARY_PATH=${.CURDIR}/../src ./fortest
-
-testhdf: $(COBJS) $(HDFLIB)/libdf.so
- $(CC) -o testhdf $(COBJS) $(HDFLIB)/libdf.so -lm
- test -d $(TESTDIR) || mkdir $(TESTDIR)
-
-fortestF: $(FOBJS) $(HDFLIB)/libdf.so
- $(FC) $(FFLAGS) -o $@ $(FOBJS) $(HDFLIB)/libdf.so -lm
-
-fortest: $(HDFLIB)/libdf.so fortest.c $(CHDRS)
- $(CC) $(CFLAGS) -o fortest fortest.c $(HDFLIB)/libdf.so -lm
-
-gentest: gentest.c $(HDFLIB)/libdf.so
- $(CC) $(CFLAGS) gentest.c -o gentest $(HDFLIB)/libdf.so -lm
-
-clean:
- -rm -f $(COBJS) testhdf $(FOBJS) $(FTESTS) \
- core *.hdf ptesthdf qtesthdf gentest *.o fortest.arg $(TESTDIR)/* \
- .depend
-
-depend:
- mkdep ${CFLAGS} ${CSRCS}
-
-install:
diff --git a/science/hdf5-18/files/hdf/util/Makefile b/science/hdf5-18/files/hdf/util/Makefile
deleted file mode 100644
index 6d4ccae200d4..000000000000
--- a/science/hdf5-18/files/hdf/util/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-# $FreeBSD$
-
-UTILS = hdf24to8 hdfcomp hdfls hdfpack hdftopal hdftor8 paltohdf \
- r8tohdf ristosds vmake vshow hdf8to24 hdf2jpeg jpeg2hdf fp2hdf \
- hdfunpac vcompat
-
-all: ${UTILS} hdfed
-
-HEOBJ = he_main.o he_cntrl.o he_disp.o he_file.o
-
-#CFLAGS += -I${PREFIX}/include -I${.CURDIR}/../src/
-CFLAGS += -I${.CURDIR}/../src/
-#LDFLAGS += -L${PREFIX}/lib -ljpeg -L${.CURDIR}/../src/ -ldf -lz
-LDFLAGS += -L${.CURDIR}/../src/ -ldf
-
-hdfed: he.h he_proto.h $(HEOBJ)
- $(CC) $(HEOBJ) $(LDFLAGS) -o hdfed
-
-test: all fptest
- env LD_LIBRARY_PATH=${.CURDIR}/../src ./testutil.sh
-
-clean:
- -rm -f *.o $(UTILS) hdfed fptest
- -rm -f o* ctx* cb* fptestf .depend
-
-depend:
- mkdep ${CFLAGS} ${UTILS:S/$/.c/g} ${HEOBJ:S/.o/.c/g}
-
-install: all
- install -c -s -o root -g wheel -m 555 ${UTILS} hdfed ${BINDIR}