aboutsummaryrefslogtreecommitdiff
path: root/science/kmovisto/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/kmovisto/Makefile')
-rw-r--r--science/kmovisto/Makefile42
1 files changed, 0 insertions, 42 deletions
diff --git a/science/kmovisto/Makefile b/science/kmovisto/Makefile
deleted file mode 100644
index be4733bf3462..000000000000
--- a/science/kmovisto/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-# ex:ts=8
-# Ports collection Makefile for: kmovisto
-# Date created: Oct 23, 2003
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= kmovisto
-PORTVERSION= 0.7.0
-PORTREVISION= 8
-CATEGORIES= science
-MASTER_SITES= http://mitglied.multimania.de/pageofmh/download/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A real 3-D molecule viewer
-
-DEPRECATED= Depends on QT3; unmaintained
-EXPIRATION_DATE= 2013-07-01
-
-USE_XORG= x11 ice xext
-USE_QT_VER= 3
-USE_GL= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|-pedantic||g ; \
- s|-fno-exceptions|-fexceptions|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-ldl||g' ${WRKSRC}/kmovisto/Makefile.in
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/kmovisto/kmovisto ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/kmovisto/docs/en/*.html ${DOCSDIR}
- @${MKDIR} ${DOCSDIR}/images
- ${INSTALL_DATA} ${WRKSRC}/kmovisto/docs/en/images/*.jpg ${DOCSDIR}/images
-.endif
-
-.include <bsd.port.mk>