aboutsummaryrefslogtreecommitdiff
path: root/science/lamprop/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/lamprop/Makefile')
-rw-r--r--science/lamprop/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/science/lamprop/Makefile b/science/lamprop/Makefile
new file mode 100644
index 000000000000..9a1e6cf2fd79
--- /dev/null
+++ b/science/lamprop/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: lamprop
+# Date created: 15 May 2005
+# Whom: rsmith@xs4all.nl
+#
+# $FreeBSD$
+#
+
+PORTNAME= lamprop
+PORTVERSION= 1.3.1
+CATEGORIES= science
+MASTER_SITES= http://www.xs4all.nl/~rsmith/software/
+
+MAINTAINER= rsmith@xs4all.nl
+COMMENT= Calculates properties of fiber reinforced composites
+
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/lamprop
+
+MAN1= lamprop.1
+MAN5= lamprop.5
+MANCOMPRESSED= yes
+
+.if defined(NOPORTDOCS)
+MAKE_ENV= NOPORTDOCS=yes
+.else
+PORTDOCS= LICENSE README NEWS
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-pipe||; s|-fmerge-constants||; s|-fno-unit-at-a-time||; s|--fast-math||' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>