aboutsummaryrefslogtreecommitdiff
path: root/science/massxpert
diff options
context:
space:
mode:
Diffstat (limited to 'science/massxpert')
-rw-r--r--science/massxpert/Makefile20
-rw-r--r--science/massxpert/distinfo5
-rw-r--r--science/massxpert/files/patch-CMakeLists.txt50
-rw-r--r--science/massxpert/files/patch-lib_cleaveSpec.cpp11
-rw-r--r--science/massxpert/files/patch-lib_propListHolder.cpp19
-rw-r--r--science/massxpert/files/patch-plugins-src_seqToolsPlugin_seqToolsPluginDlg.cpp11
-rw-r--r--science/massxpert/pkg-descr2
-rw-r--r--science/massxpert/pkg-plist27
8 files changed, 52 insertions, 93 deletions
diff --git a/science/massxpert/Makefile b/science/massxpert/Makefile
index 6ce98a6f6fd6..2800386124b9 100644
--- a/science/massxpert/Makefile
+++ b/science/massxpert/Makefile
@@ -2,18 +2,14 @@
# $FreeBSD$
PORTNAME= massxpert
-PORTVERSION= 3.4.0
-PORTREVISION= 12
+DISTVERSION= 3.6.1
CATEGORIES= science
-MASTER_SITES= http://download.tuxfamily.org/massxpert/source/
MAINTAINER= ports@FreeBSD.org
COMMENT= massXpert software for (bio)chemists
LICENSE= GPLv3
-
-DEPRECATED= Qt4 has been EOL since december 2015
-EXPIRATION_DATE= 2019-03-15
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
LIB_DEPENDS= libpcre.so:devel/pcre \
@@ -22,13 +18,15 @@ LIB_DEPENDS= libpcre.so:devel/pcre \
libexpat.so:textproc/expat2 \
libfontconfig.so:x11-fonts/fontconfig
-USE_GCC= any
-USES= cmake gettext qt:4 tar:bzip2
+USES= cmake gettext gnome qt:5 tar:bzip2
+USE_GITLAB= yes
+GL_SITE= https://salsa.debian.org/
+GL_ACCOUNT= debichem-team
+GL_COMMIT= c229f4a1abde3c20b83a90e50f9c5d79104dfa5f
+USE_GCC= any # build breaks in clang
USE_XORG= ice sm x11 xau xcb xdmcp xext xrender
USE_GNOME= glib20
-USE_QT= corelib gui xml rcc_build qmake_build uic_build moc_build \
- svg
+USE_QT= core gui svg xml widgets buildtools_build qmake_build
USE_LDCONFIG= yes
-MAKE_JOBS_UNSAFE= yes
.include <bsd.port.mk>
diff --git a/science/massxpert/distinfo b/science/massxpert/distinfo
index 4089e4a89aa7..6ac8bd9df020 100644
--- a/science/massxpert/distinfo
+++ b/science/massxpert/distinfo
@@ -1,2 +1,3 @@
-SHA256 (massxpert-3.4.0.tar.bz2) = b06314722b4cbdf68dc76e55933a79487848c655fc65341a8dbc707ed89cc9e8
-SIZE (massxpert-3.4.0.tar.bz2) = 16544044
+TIMESTAMP = 1552172511
+SHA256 (debichem-team-massxpert-c229f4a1abde3c20b83a90e50f9c5d79104dfa5f_GL0.tar.gz) = 28bdfb73a12c3f198450f1cf2aac57b647168006ea82d5eee7af0caaf0a2841e
+SIZE (debichem-team-massxpert-c229f4a1abde3c20b83a90e50f9c5d79104dfa5f_GL0.tar.gz) = 17469770
diff --git a/science/massxpert/files/patch-CMakeLists.txt b/science/massxpert/files/patch-CMakeLists.txt
index e1b2d600d479..dd14622c2dc3 100644
--- a/science/massxpert/files/patch-CMakeLists.txt
+++ b/science/massxpert/files/patch-CMakeLists.txt
@@ -1,29 +1,31 @@
---- CMakeLists.txt.orig 2010-05-11 01:23:01.000000000 +0800
-+++ CMakeLists.txt 2010-05-21 20:17:36.000000000 +0800
-@@ -153,7 +153,7 @@
- # The manual page
- IF (UNIX AND NOT APPLE)
- INSTALL (FILES massxpert.1
-- DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man1)
-+ DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man1)
- ENDIF (UNIX AND NOT APPLE)
+--- CMakeLists.txt.orig 2019-03-09 23:08:57 UTC
++++ CMakeLists.txt
+@@ -130,8 +130,8 @@ CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/CMake
+ # install stuff
- ###############
-@@ -188,7 +188,7 @@
- # The manual pages (data)
- IF (UNIX AND NOT APPLE)
- INSTALL (FILES massxpert-data.7
+ # The license file
+-INSTALL(FILES COPYING
+- DESTINATION ${MASSXPERT_DOC_DIR})
++#INSTALL(FILES COPYING
++# DESTINATION ${MASSXPERT_DOC_DIR})
+
+ # The desktop file
+ IF(UNIX AND NOT APPLE)
+@@ -142,7 +142,7 @@ ENDIF(UNIX AND NOT APPLE)
+ # The manual page
+ IF(UNIX AND NOT APPLE)
+ INSTALL(FILES massxpert.1
+- DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man1)
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man1)
+ ENDIF(UNIX AND NOT APPLE)
+
+
+@@ -169,7 +169,7 @@ IF(${BUILD_DATA})
+ # The manual pages(data)
+ IF(UNIX AND NOT APPLE)
+ INSTALL(FILES massxpert-data.7
- DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man7)
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man7)
- ENDIF (UNIX AND NOT APPLE)
+ ENDIF(UNIX AND NOT APPLE)
#################
-@@ -222,7 +222,7 @@
- # The manual pages (user manual)
- IF (UNIX AND NOT APPLE)
- INSTALL (FILES massxpert-doc.7
-- DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man7)
-+ DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man7)
- ENDIF (UNIX AND NOT APPLE)
-
-
diff --git a/science/massxpert/files/patch-lib_cleaveSpec.cpp b/science/massxpert/files/patch-lib_cleaveSpec.cpp
deleted file mode 100644
index 904af6ac2aca..000000000000
--- a/science/massxpert/files/patch-lib_cleaveSpec.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/cleaveSpec.cpp.orig 2012-12-25 21:02:43 UTC
-+++ lib/cleaveSpec.cpp
-@@ -427,7 +427,7 @@ namespace massXpert
- return false;
-
-
-- if (parse() == -1)
-+ if (parse() == false)
- return false;
-
- // If there are rules, we have to check them all.
diff --git a/science/massxpert/files/patch-lib_propListHolder.cpp b/science/massxpert/files/patch-lib_propListHolder.cpp
deleted file mode 100644
index b6f037a8009c..000000000000
--- a/science/massxpert/files/patch-lib_propListHolder.cpp
+++ /dev/null
@@ -1,19 +0,0 @@
-Fixes the build with GCC 6 (in addition to fixing an actual bug).
-
-/wrkdirs/usr/ports/science/massxpert/work/massxpert-3.4.0/lib/propListHolder.cpp: In member function 'bool massXpert::PropListHolder::removeProp(const QString&)':
-/wrkdirs/usr/ports/science/massxpert/work/massxpert-3.4.0/lib/propListHolder.cpp:216:2: error: this 'if' clause does not guard... [-Werror=misleading-indentation]
- if(m_propList.at(iter)->name() == name);
- ^~
-/wrkdirs/usr/ports/science/massxpert/work/massxpert-3.4.0/lib/propListHolder.cpp:217:2: note: ...this statement, but the latter is misleadingly indented as if it is guarded by the 'if'
- {
---- lib/propListHolder.cpp.orig 2017-07-26 17:06:18 UTC
-+++ lib/propListHolder.cpp
-@@ -213,7 +213,7 @@ namespace massXpert
- {
- for (int iter = 0; iter < m_propList.size(); ++iter)
- {
-- if(m_propList.at(iter)->name() == name);
-+ if(m_propList.at(iter)->name() == name)
- {
- m_propList.removeAt(iter);
-
diff --git a/science/massxpert/files/patch-plugins-src_seqToolsPlugin_seqToolsPluginDlg.cpp b/science/massxpert/files/patch-plugins-src_seqToolsPlugin_seqToolsPluginDlg.cpp
deleted file mode 100644
index 46c261227c5f..000000000000
--- a/science/massxpert/files/patch-plugins-src_seqToolsPlugin_seqToolsPluginDlg.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins-src/seqToolsPlugin/seqToolsPluginDlg.cpp.orig 2012-12-25 21:02:43 UTC
-+++ plugins-src/seqToolsPlugin/seqToolsPluginDlg.cpp
-@@ -215,7 +215,7 @@ SeqToolsPluginDlg::loadDictionary ()
-
- QStringList stringList = line.split (">", QString::SkipEmptyParts);
-
-- if (!stringList.size () == 2)
-+ if (stringList.size () != 2)
- {
- QMessageBox::warning (this,
- tr ("Sequence Manipulation Tools Plugin"),
diff --git a/science/massxpert/pkg-descr b/science/massxpert/pkg-descr
index 6a571361839a..6ad116f435a0 100644
--- a/science/massxpert/pkg-descr
+++ b/science/massxpert/pkg-descr
@@ -17,4 +17,4 @@ to another (using a dictionary, like between the 1-letter code and the 3-letter
code of proteins) 2) conversion of number format according to any localized
number format 3) sort mass lists.
-WWW: http://massxpert.tuxfamily.org/
+WWW: https://salsa.debian.org/debichem-team/massxpert
diff --git a/science/massxpert/pkg-plist b/science/massxpert/pkg-plist
index 1a360a985ed4..e4002e2c2c02 100644
--- a/science/massxpert/pkg-plist
+++ b/science/massxpert/pkg-plist
@@ -1,11 +1,13 @@
bin/massxpert
-lib/massxpert/plugins/libmassListSorterPlugin.so
-lib/massxpert/plugins/libseqToolsPlugin.so
-lib/massxpert/plugins/libnumeralsLocaleConverterPlugin.so
man/man1/massxpert.1.gz
man/man7/massxpert-data.7.gz
-%%DOCSDIR%%/COPYING
share/applications/massxpert.desktop
+%%DATADIR%%/chem_pad.conf
+%%DATADIR%%/dictionaries/codon-to-protein-1.dic
+%%DATADIR%%/dictionaries/codon-to-protein-3.dic
+%%DATADIR%%/dictionaries/pdb-protein-to-mxp.dic
+%%DATADIR%%/dictionaries/protein-1-to-3.dic
+%%DATADIR%%/dictionaries/protein-3-to-1.dic
%%DATADIR%%/locales/massxpert_fr.qm
%%DATADIR%%/pol-chem-defs/dna/adenine.svg
%%DATADIR%%/pol-chem-defs/dna/biotlink.svg
@@ -49,8 +51,8 @@ share/applications/massxpert.desktop
%%DATADIR%%/pol-chem-defs/nucac/oxidation.svg
%%DATADIR%%/pol-chem-defs/nucac/phospho.svg
%%DATADIR%%/pol-chem-defs/nucac/ps-dadenine.svg
-%%DATADIR%%/pol-chem-defs/nucac/ps-dguanine.svg
%%DATADIR%%/pol-chem-defs/nucac/ps-dcytosine.svg
+%%DATADIR%%/pol-chem-defs/nucac/ps-dguanine.svg
%%DATADIR%%/pol-chem-defs/nucac/ps-dthymine.svg
%%DATADIR%%/pol-chem-defs/nucac/ps-radenine.svg
%%DATADIR%%/pol-chem-defs/nucac/ps-rcytosine.svg
@@ -76,7 +78,9 @@ share/applications/massxpert.desktop
%%DATADIR%%/pol-chem-defs/protein-1-letter/disulfidebond-cross-link.svg
%%DATADIR%%/pol-chem-defs/protein-1-letter/glutamate.svg
%%DATADIR%%/pol-chem-defs/protein-1-letter/glutamine.svg
+%%DATADIR%%/pol-chem-defs/protein-1-letter/glutamylation.svg
%%DATADIR%%/pol-chem-defs/protein-1-letter/glycine.svg
+%%DATADIR%%/pol-chem-defs/protein-1-letter/glycylation.svg
%%DATADIR%%/pol-chem-defs/protein-1-letter/histidine.svg
%%DATADIR%%/pol-chem-defs/protein-1-letter/hydroxylation.svg
%%DATADIR%%/pol-chem-defs/protein-1-letter/isoleucine.svg
@@ -119,12 +123,12 @@ share/applications/massxpert.desktop
%%DATADIR%%/pol-chem-defs/protein-3-letters/leucine.svg
%%DATADIR%%/pol-chem-defs/protein-3-letters/lysine.svg
%%DATADIR%%/pol-chem-defs/protein-3-letters/methionine.svg
-%%DATADIR%%/pol-chem-defs/protein-3-letters/phospho.svg
%%DATADIR%%/pol-chem-defs/protein-3-letters/modification_dictionary
%%DATADIR%%/pol-chem-defs/protein-3-letters/monomer_dictionary
%%DATADIR%%/pol-chem-defs/protein-3-letters/oxidation.svg
%%DATADIR%%/pol-chem-defs/protein-3-letters/pdb-code-conversion.dic
%%DATADIR%%/pol-chem-defs/protein-3-letters/phenylalanine.svg
+%%DATADIR%%/pol-chem-defs/protein-3-letters/phospho.svg
%%DATADIR%%/pol-chem-defs/protein-3-letters/proline.svg
%%DATADIR%%/pol-chem-defs/protein-3-letters/protein-3-letters.xml
%%DATADIR%%/pol-chem-defs/protein-3-letters/protonloss.svg
@@ -188,6 +192,7 @@ share/applications/massxpert.desktop
%%DATADIR%%/pol-chem-defs/saccharide/xylulose-text.svg
%%DATADIR%%/pol-chem-defs/saccharide/xylulose.svg
%%DATADIR%%/pol-seqs/17-mer-ps-po-dna-chimera.mxp
+%%DATADIR%%/pol-seqs/beta-2-tubulin.mxp
%%DATADIR%%/pol-seqs/centrin-2-human.mxp
%%DATADIR%%/pol-seqs/cerulean-histag.mxp
%%DATADIR%%/pol-seqs/chicken-telokin.mxp
@@ -195,17 +200,11 @@ share/applications/massxpert.desktop
%%DATADIR%%/pol-seqs/cyan-fluorescent-protein-h148d-histag.mxp
%%DATADIR%%/pol-seqs/cyan-fluorescent-protein.mxp
%%DATADIR%%/pol-seqs/horse-myoglobin.mxp
+%%DATADIR%%/pol-seqs/insulin-a-ox.mxp
+%%DATADIR%%/pol-seqs/insulin-b-ox.mxp
%%DATADIR%%/pol-seqs/kunitz-inhibitor-human.mxp
%%DATADIR%%/pol-seqs/leu-enkephalin.mxp
%%DATADIR%%/pol-seqs/protein-1-letter.mxp
%%DATADIR%%/pol-seqs/protein-3-letters.mxp
%%DATADIR%%/pol-seqs/tev-protease-his-tag.mxp
%%DATADIR%%/pol-seqs/yellow-fluorescent-protein.mxp
-%%DATADIR%%/pol-seqs/insulin-a-ox.mxp
-%%DATADIR%%/pol-seqs/insulin-b-ox.mxp
-%%DATADIR%%/dictionaries/codon-to-protein-1.dic
-%%DATADIR%%/dictionaries/codon-to-protein-3.dic
-%%DATADIR%%/dictionaries/pdb-protein-to-mxp.dic
-%%DATADIR%%/dictionaries/protein-1-to-3.dic
-%%DATADIR%%/dictionaries/protein-3-to-1.dic
-%%DATADIR%%/chem_pad.conf